newer versions of sdcc dropped support for xa51, compiles fine without so change...
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Apr 2011 19:42:27 +0000 (19:42 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Apr 2011 19:42:27 +0000 (19:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26473 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/firmwarehotplug/Makefile

index 17bc11f..d30cc22 100644 (file)
@@ -48,7 +48,7 @@ define Package/firmwarehotplug/install
 endef
 
 define Require/working-sdcc
-       sdcc -v 2>&1 | awk '($$$$1 == "SDCC") && ($$$$3 == "mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08") { print "ok" }' | grep ok > /dev/null
+       sdcc -v 2>&1 | awk '($$$$1 == "SDCC") && ($$$$3 ~ "mcs51/gbz80/z80/ds390/pic16/pic14/TININative/") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call RequireCommand,sdcc, \