packages/bluez-utils: rename uci config file, cleanup
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Nov 2011 11:49:08 +0000 (11:49 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 Nov 2011 11:49:08 +0000 (11:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29231 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bluez-utils/Makefile
utils/bluez-utils/files/bluetooth.conf [deleted file]
utils/bluez-utils/files/bluetooth.config [new file with mode: 0644]

index 5b4dbee..c0a0f6e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
@@ -56,18 +56,16 @@ define Build/Compile
                all install
 endef
 
-#copy bluetooth.conf nach /etc/dbus-1/system.d/
-
 define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/bluetooth
-       $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
-       $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
+       $(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/hcid/hcid.conf $(1)/etc/bluetooth/
+       $(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/rfcomm/rfcomm.conf $(1)/etc/bluetooth/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
+       $(INSTALL_DATA) ./files/bluetooth.config $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
        $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d
diff --git a/utils/bluez-utils/files/bluetooth.conf b/utils/bluez-utils/files/bluetooth.conf
deleted file mode 100644 (file)
index 42f390c..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-config hcid
-#      option config   /etc/bluetooth/hcid.conf
-       option enabled  1
-
-config hciattach
-       option initspeed        115200
-       option tty      ttyS1
-       option type     csr
-       option speed    115200
-       option flow     noflow
-       option enabled  0
-
-config rfcomm
-#      option config   /etc/bluetooth/rfcomm.conf
-       option enabled  0
-
-config dund
-       option listen   true
-       option persist  true
-       option msdun    true
-       option interface dund
-       option unit     1
-       option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
-       option enabled  0
-
-config pand
-       option listen   true
-       option autozap  true
-       option role     "NAP"
-       option master   true
-       option persist  true
-       option enabled  0
diff --git a/utils/bluez-utils/files/bluetooth.config b/utils/bluez-utils/files/bluetooth.config
new file mode 100644 (file)
index 0000000..42f390c
--- /dev/null
@@ -0,0 +1,32 @@
+config hcid
+#      option config   /etc/bluetooth/hcid.conf
+       option enabled  1
+
+config hciattach
+       option initspeed        115200
+       option tty      ttyS1
+       option type     csr
+       option speed    115200
+       option flow     noflow
+       option enabled  0
+
+config rfcomm
+#      option config   /etc/bluetooth/rfcomm.conf
+       option enabled  0
+
+config dund
+       option listen   true
+       option persist  true
+       option msdun    true
+       option interface dund
+       option unit     1
+       option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
+       option enabled  0
+
+config pand
+       option listen   true
+       option autozap  true
+       option role     "NAP"
+       option master   true
+       option persist  true
+       option enabled  0