[package] update squid to 2.7STABLE9, thanks to Tomasz Mon
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Jul 2010 22:56:47 +0000 (22:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Jul 2010 22:56:47 +0000 (22:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22420 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/squid/Makefile
net/squid/patches/001-cross_compile.patch
net/squid/patches/002-no_sslv2.patch
net/squid/patches/003-configure.patch
net/squid/patches/004-include-autoconf.patch
net/squid/patches/005-lib-makefile.patch

index 5874d9d..f25dca4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=2.6.STABLE23
+PKG_VERSION:=2.7.STABLE9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.6/
-PKG_MD5SUM:=71aa24580f8a538ad84037bf2ac6f078
+PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v2/2.7/
+PKG_MD5SUM:=3c6642c85470b1079207d43bba25a819
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,9 +31,9 @@ define Package/squid
 endef
 
 define Package/squid/description
-       Squid is a high-performance proxy caching server for web clients, 
-       supporting FTP, gopher, and HTTP data objects. Unlike traditional 
-       caching software, Squid handles all requests in a single, 
+       Squid is a high-performance proxy caching server for web clients,
+       supporting FTP, gopher, and HTTP data objects. Unlike traditional
+       caching software, Squid handles all requests in a single,
        non-blocking, I/O-driven process.
 endef
 
@@ -160,7 +160,7 @@ define Package/squid/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/squid
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger} $(1)/usr/lib/squid/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/squid/{unlinkd,pinger,logfile-daemon} $(1)/usr/lib/squid/
 endef
 
 define Package/squid-mod-cachemgr/install
index 1678120..f2648d9 100644 (file)
@@ -1,7 +1,5 @@
-Index: squid-2.6.STABLE23/src/ctype.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ squid-2.6.STABLE23/src/ctype.c     2009-11-11 14:01:34.000000000 +0100
+--- /dev/null
++++ b/src/ctype.c
 @@ -0,0 +1,546 @@
 +/*
 + Static ctype data for IFC-7.1 / RedHat-9 workaround.
@@ -549,11 +547,9 @@ Index: squid-2.6.STABLE23/src/ctype.c
 +const uint32_t *__ctype32_tolower = b (uint32_t, tolower, 128);
 +const uint32_t *__ctype32_toupper = b (uint32_t, toupper, 128);
 +
-Index: squid-2.6.STABLE23/src/Makefile.in
-===================================================================
---- squid-2.6.STABLE23.orig/src/Makefile.in    2009-09-17 01:33:37.000000000 +0200
-+++ squid-2.6.STABLE23/src/Makefile.in 2009-11-11 14:02:33.000000000 +0100
-@@ -1191,6 +1191,9 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1234,6 +1234,9 @@ squid.conf.default: cf_parser.h
        true
  
  cf_parser.h: cf.data cf_gen$(EXEEXT)
index ee940c9..c5c0f0e 100644 (file)
@@ -1,8 +1,6 @@
-Index: squid-2.6.STABLE14/src/ssl_support.c
-===================================================================
---- squid-2.6.STABLE14.orig/src/ssl_support.c  2007-07-25 16:04:15.000000000 -0500
-+++ squid-2.6.STABLE14/src/ssl_support.c       2007-07-25 16:04:15.000000000 -0500
-@@ -442,10 +442,12 @@
+--- a/src/ssl_support.c
++++ b/src/ssl_support.c
+@@ -446,10 +446,12 @@ sslCreateServerContext(const char *certf
      ERR_clear_error();
      debug(83, 1) ("Initialising SSL.\n");
      switch (version) {
index d8453b6..c58b29e 100644 (file)
@@ -1,8 +1,6 @@
-Index: squid-2.6.STABLE23/configure
-===================================================================
---- squid-2.6.STABLE23.orig/configure  2009-09-17 01:35:13.000000000 +0200
-+++ squid-2.6.STABLE23/configure       2009-11-11 14:19:11.000000000 +0100
-@@ -5053,10 +5053,6 @@
+--- a/configure
++++ b/configure
+@@ -5059,10 +5059,6 @@ _ACEOF
    if test -z "$SSLLIB"; then
      SSLLIB="-lcrypto" # for MD5 routines
    fi
@@ -13,7 +11,7 @@ Index: squid-2.6.STABLE23/configure
    CPPFLAGS="${SSLFLAGS} $CPPFLAGS"
  fi
  
-@@ -26292,7 +26288,7 @@
+@@ -27318,7 +27314,7 @@ else
  See \`config.log' for more details." >&5
  $as_echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -22,7 +20,7 @@ Index: squid-2.6.STABLE23/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -26455,8 +26451,7 @@
+@@ -27481,8 +27477,7 @@ else
    { { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  $as_echo "$as_me: error: cannot run test program while cross compiling
@@ -32,7 +30,7 @@ Index: squid-2.6.STABLE23/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -26707,7 +26702,7 @@
+@@ -27733,7 +27728,7 @@ else
  See \`config.log' for more details." >&5
  $as_echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -41,7 +39,7 @@ Index: squid-2.6.STABLE23/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -26789,7 +26784,7 @@
+@@ -27815,7 +27810,7 @@ else
  See \`config.log' for more details." >&5
  $as_echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
index 676cb98..9ed4360 100644 (file)
@@ -1,8 +1,6 @@
-Index: squid-2.6.STABLE14/include/autoconf.h.in
-===================================================================
---- squid-2.6.STABLE14.orig/include/autoconf.h.in      2007-07-25 16:04:15.000000000 -0500
-+++ squid-2.6.STABLE14/include/autoconf.h.in   2007-07-25 16:04:16.000000000 -0500
-@@ -319,10 +319,10 @@
+--- a/include/autoconf.h.in
++++ b/include/autoconf.h.in
+@@ -313,10 +313,10 @@
  #undef HAVE_OPENSSL_ERR_H
  
  /* Define to 1 if you have the <openssl/md5.h> header file. */
index 1f094db..06b7955 100644 (file)
@@ -1,38 +1,37 @@
-Index: squid-2.6.STABLE23/lib/Makefile.in
-===================================================================
---- squid-2.6.STABLE23.orig/lib/Makefile.in    2009-09-17 01:33:17.000000000 +0200
-+++ squid-2.6.STABLE23/lib/Makefile.in 2009-11-11 14:16:09.000000000 +0100
-@@ -61,7 +61,9 @@
+--- a/lib/Makefile.in
++++ b/lib/Makefile.in
+@@ -60,8 +60,10 @@ am__libmiscutil_a_SOURCES_DIST = Array.c
+       rfc1123.c rfc1738.c rfc2617.c safe_inet_addr.c snprintf.c \
        splay.c Stack.c strsep.c stub_memaccount.c util.c uudecode.c \
        win32lib.c
- @NEED_OWN_MD5_TRUE@am__objects_1 = md5.$(OBJEXT)
 +@NEED_OWN_MD5_TRUE@am__host_objects_1 = md5.$(HOST_OBJEXT)
- @NEED_OWN_SNPRINTF_TRUE@am__objects_2 = snprintf.$(OBJEXT)
+ @NEED_OWN_SNPRINTF_TRUE@am__objects_1 = snprintf.$(OBJEXT)
+ @NEED_OWN_STRSEP_TRUE@am__objects_2 = strsep.$(OBJEXT)
 +@NEED_OWN_SNPRINTF_TRUE@am__host_objects_2 = snprintf.$(HOST_OBJEXT)
- @NEED_OWN_STRSEP_TRUE@am__objects_3 = strsep.$(OBJEXT)
- @ENABLE_MINGW32SPECIFIC_TRUE@am__objects_4 = win32lib.$(OBJEXT)
+ @ENABLE_MINGW32SPECIFIC_TRUE@am__objects_3 = win32lib.$(OBJEXT)
  am_libmiscutil_a_OBJECTS = Array.$(OBJEXT) base64.$(OBJEXT) \
-@@ -72,7 +74,19 @@
-       $(am__objects_2) splay.$(OBJEXT) Stack.$(OBJEXT) \
-       $(am__objects_3) stub_memaccount.$(OBJEXT) util.$(OBJEXT) \
-       uudecode.$(OBJEXT) $(am__objects_4)
+       getfullhostname.$(OBJEXT) hash.$(OBJEXT) heap.$(OBJEXT) \
+@@ -71,7 +73,19 @@ am_libmiscutil_a_OBJECTS = Array.$(OBJEX
+       $(am__objects_1) splay.$(OBJEXT) Stack.$(OBJEXT) \
+       $(am__objects_2) stub_memaccount.$(OBJEXT) util.$(OBJEXT) \
+       uudecode.$(OBJEXT) $(am__objects_3)
 +am_libmiscutil_a_HOST_OBJECTS = Array.$(HOST_OBJEXT) \
-+                      base64.$(HOST_OBJEXT) getfullhostname.$(HOST_OBJEXT) \
-+                      hash.$(HOST_OBJEXT) heap.$(HOST_OBJEXT) \
-+                      html_quote.$(HOST_OBJEXT) iso3307.$(HOST_OBJEXT) \
-+                      $(am__host_objects_1) radix.$(HOST_OBJEXT) \
-+                      rfc1035.$(HOST_OBJEXT) rfc1123.$(HOST_OBJEXT) \
-+                      rfc1738.$(HOST_OBJEXT) rfc2617.$(HOST_OBJEXT) \
-+                      safe_inet_addr.$(HOST_OBJEXT) $(am__host_objects_2) \
-+                      splay.$(HOST_OBJEXT) Stack.$(HOST_OBJEXT) \
-+                      stub_memaccount.$(HOST_OBJEXT) util.$(HOST_OBJEXT) \
-+                      uudecode.$(HOST_OBJEXT)
++      base64.$(HOST_OBJEXT) getfullhostname.$(HOST_OBJEXT) \
++      hash.$(HOST_OBJEXT) heap.$(HOST_OBJEXT) \
++      html_quote.$(HOST_OBJEXT) iso3307.$(HOST_OBJEXT) \
++      $(am__host_objects_1) radix.$(HOST_OBJEXT) \
++      rfc1035.$(HOST_OBJEXT) rfc1123.$(HOST_OBJEXT) \
++      rfc1738.$(HOST_OBJEXT) rfc2617.$(HOST_OBJEXT) \
++      safe_inet_addr.$(HOST_OBJEXT) $(am__host_objects_2) \
++      splay.$(HOST_OBJEXT) Stack.$(HOST_OBJEXT) \
++      stub_memaccount.$(HOST_OBJEXT) util.$(HOST_OBJEXT) \
++      uudecode.$(HOST_OBJEXT)
  libmiscutil_a_OBJECTS = $(am_libmiscutil_a_OBJECTS)
 +libmiscutil_a_HOST_OBJECTS = $(am_libmiscutil_a_HOST_OBJECTS)
  libntlmauth_a_AR = $(AR) $(ARFLAGS)
  libntlmauth_a_DEPENDENCIES = @LIBOBJS@
  am_libntlmauth_a_OBJECTS = ntlmauth.$(OBJEXT)
-@@ -90,15 +104,19 @@
+@@ -89,15 +103,19 @@ depcomp = $(SHELL) $(top_srcdir)/cfgaux/
  am__depfiles_maybe = depfiles
  COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
        $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
@@ -54,7 +53,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  ETAGS = etags
  CTAGS = ctags
  DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-@@ -106,6 +124,7 @@
+@@ -105,6 +123,7 @@ ACLOCAL = @ACLOCAL@
  ALLOCA = @ALLOCA@
  AMTAR = @AMTAR@
  AR = @AR@
@@ -62,7 +61,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  AR_R = @AR_R@
  AUTH_LIBS = @AUTH_LIBS@
  AUTH_MODULES = @AUTH_MODULES@
-@@ -118,6 +137,7 @@
+@@ -117,6 +136,7 @@ BASIC_AUTH_HELPERS = @BASIC_AUTH_HELPERS
  CACHE_HTTP_PORT = @CACHE_HTTP_PORT@
  CACHE_ICP_PORT = @CACHE_ICP_PORT@
  CC = @CC@
@@ -70,8 +69,8 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  CCDEPMODE = @CCDEPMODE@
  CFLAGS = @CFLAGS@
  CGIEXT = @CGIEXT@
-@@ -165,6 +185,8 @@
- NEGOTIATE_AUTH_HELPERS = @NEGOTIATE_AUTH_HELPERS@
+@@ -164,6 +184,8 @@ NEGOTIATE_AUTH_HELPERS = @NEGOTIATE_AUTH
+ NIS_LIBS = @NIS_LIBS@
  NTLM_AUTH_HELPERS = @NTLM_AUTH_HELPERS@
  OBJEXT = @OBJEXT@
 +HOST_OBJEXT = @OBJEXT@.$(shell uname -m)
@@ -79,7 +78,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  OPT_DEFAULT_HOSTS = @OPT_DEFAULT_HOSTS@
  PACKAGE = @PACKAGE@
  PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
-@@ -264,6 +286,7 @@
+@@ -261,6 +283,7 @@ EXTRA_LIBRARIES = \
  noinst_LIBRARIES = \
        @LIBDLMALLOC@ \
        libmiscutil.a \
@@ -87,7 +86,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
        libntlmauth.a \
        @LIBREGEX@ \
        $(LIBSSPWIN32)
-@@ -298,9 +321,34 @@
+@@ -300,9 +323,34 @@ libmiscutil_a_SOURCES = \
        uudecode.c \
        $(WIN32SRC)
  
@@ -122,7 +121,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  # $(top_srcdir)/include/version.h should be a dependency
  libregex_a_SOURCES = \
        GNUregex.c
-@@ -321,7 +369,7 @@
+@@ -323,7 +371,7 @@ INCLUDES = -I$(top_builddir)/include -I$
  all: all-am
  
  .SUFFIXES:
@@ -131,7 +130,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am  $(am__configure_deps)
        @for dep in $?; do \
          case '$(am__configure_deps)' in \
-@@ -358,10 +406,13 @@
+@@ -360,10 +408,13 @@ libdlmalloc.a: $(libdlmalloc_a_OBJECTS)
        -rm -f libdlmalloc.a
        $(libdlmalloc_a_AR) libdlmalloc.a $(libdlmalloc_a_OBJECTS) $(libdlmalloc_a_LIBADD)
        $(RANLIB) libdlmalloc.a
@@ -146,7 +145,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  libntlmauth.a: $(libntlmauth_a_OBJECTS) $(libntlmauth_a_DEPENDENCIES) 
        -rm -f libntlmauth.a
        $(libntlmauth_a_AR) libntlmauth.a $(libntlmauth_a_OBJECTS) $(libntlmauth_a_LIBADD)
-@@ -412,6 +463,21 @@
+@@ -417,6 +468,21 @@ distclean-compile:
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/util.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/uudecode.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/win32lib.Po@am__quote@
@@ -168,7 +167,7 @@ Index: squid-2.6.STABLE23/lib/Makefile.in
  
  .c.o:
  @am__fastdepCC_TRUE@  $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@@ -420,6 +486,9 @@
+@@ -425,6 +491,9 @@ distclean-compile:
  @AMDEP_TRUE@@am__fastdepCC_FALSE@     DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
  @am__fastdepCC_FALSE@ $(COMPILE) -c $<