btrfs-progs: moved to github
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Jan 2015 17:51:21 +0000 (17:51 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 29 Jan 2015 17:51:21 +0000 (17:51 +0000)
https://github.com/openwrt/packages/commit/5b9977c6a75c22423fd45081bcfcb8c9557191a5

Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@44200 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/btrfs-progs/Makefile [deleted file]
utils/btrfs-progs/files/btrfs-scan.init [deleted file]
utils/btrfs-progs/patches/001-Makefile-gcc-fix [deleted file]

diff --git a/utils/btrfs-progs/Makefile b/utils/btrfs-progs/Makefile
deleted file mode 100644 (file)
index f93b9ac..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=btrfs-progs
-PKG_VERSION:=0.19
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/
-PKG_MD5SUM:=69e29ecd922e3f9dcb74a3a8f80b4f68
-
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/btrfs-progs
-  SECTION:=utils
-  CATEGORY:=Utilities
-  SUBMENU:=Filesystem
-  DEPENDS:=+libuuid +zlib
-  TITLE:=Btrfs filesystems utilities
-  URL:=http://btrfs.wiki.kernel.org/
-endef
-
-define Package/btrfs-progs/description
- Btrfs is a new copy on write filesystem for Linux aimed at implementing
- advanced features while focusing on fault tolerance, repair and easy
- administration. Initially developed by Oracle, Btrfs is licensed under the
- GPL and open for contribution from anyone.
-endef
-
-progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck
-
-MAKE_FLAGS+=\
-       CC="$(TARGET_CC)" \
-       CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       LDFLAGS="$(TARGET_LDFLAGS)" \
-       prefix=/usr \
-       DESTDIR=$(PKG_INSTALL_DIR)
-
-define Package/btrfs-progs/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(addprefix $(PKG_INSTALL_DIR)/usr/bin/, $(progs)) $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/btrfs-scan.init $(1)/etc/init.d/btrfs-scan
-endef
-
-$(eval $(call BuildPackage,btrfs-progs))
diff --git a/utils/btrfs-progs/files/btrfs-scan.init b/utils/btrfs-progs/files/btrfs-scan.init
deleted file mode 100644 (file)
index f1264ee..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2009 OpenWrt.org
-
-START=19
-
-start() {
-       grep -q btrfs /proc/modules && /usr/bin/btrfsctl -a
-}
-
diff --git a/utils/btrfs-progs/patches/001-Makefile-gcc-fix b/utils/btrfs-progs/patches/001-Makefile-gcc-fix
deleted file mode 100644 (file)
index 37da622..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 8097b5a..63a734b 100644
---- a/Makefile
-+++ b/Makefile
-@@ -36,37 +36,37 @@ version:
-       bash version.sh
- btrfsctl: $(objects) btrfsctl.o
--      gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
- btrfs-vol: $(objects) btrfs-vol.o
--      gcc $(CFLAGS) -o btrfs-vol btrfs-vol.o $(objects) $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfs-vol btrfs-vol.o $(objects) $(LDFLAGS) $(LIBS)
- btrfs-show: $(objects) btrfs-show.o
--      gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
- btrfsck: $(objects) btrfsck.o
--      gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
- mkfs.btrfs: $(objects) mkfs.o
--      gcc $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o $(LDFLAGS) $(LIBS)
- btrfs-debug-tree: $(objects) debug-tree.o
--      gcc $(CFLAGS) -o btrfs-debug-tree $(objects) debug-tree.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfs-debug-tree $(objects) debug-tree.o $(LDFLAGS) $(LIBS)
- btrfstune: $(objects) btrfstune.o
--      gcc $(CFLAGS) -o btrfstune $(objects) btrfstune.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfstune $(objects) btrfstune.o $(LDFLAGS) $(LIBS)
- btrfs-image: $(objects) btrfs-image.o
--      gcc $(CFLAGS) -o btrfs-image $(objects) btrfs-image.o -lpthread -lz $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfs-image $(objects) btrfs-image.o -lpthread -lz $(LDFLAGS) $(LIBS)
- dir-test: $(objects) dir-test.o
--      gcc $(CFLAGS) -o dir-test $(objects) dir-test.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o dir-test $(objects) dir-test.o $(LDFLAGS) $(LIBS)
- quick-test: $(objects) quick-test.o
--      gcc $(CFLAGS) -o quick-test $(objects) quick-test.o $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o quick-test $(objects) quick-test.o $(LDFLAGS) $(LIBS)
- convert: $(objects) convert.o
--      gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
-+      $(CC) $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
- manpages:
-       cd man; make