[packages] debootstrap: update to 1.0.48
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Apr 2013 18:12:14 +0000 (18:12 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 30 Apr 2013 18:12:14 +0000 (18:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@36501 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/debootstrap/Makefile
admin/debootstrap/patches/100-busybox_fix.patch

index 63d98fa..e8e9472 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Copyright (C) 2010 Gianluigi Tiesi <sherpya@netfarm.it>
 #
 # Copyright (C) 2010 Gianluigi Tiesi <sherpya@netfarm.it>
-# Copyright (C) 2011-2012 OpenWrt.org
+# Copyright (C) 2011-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=debootstrap
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=debootstrap
-PKG_VERSION:=1.0.42
+PKG_VERSION:=1.0.48
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_VERSION)_all.udeb
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debootstrap
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_VERSION)_all.udeb
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debootstrap
-PKG_MD5SUM:=749638b8afc0c3e2a06c9b31cfe40b55
+PKG_MD5SUM:=fae3ba2258e41e17bcb77bbe84d26b2e
 
 UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.xz | xzcat | tar -C $(1) -xf -
 
 
 UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.xz | xzcat | tar -C $(1) -xf -
 
@@ -25,8 +25,7 @@ define Package/debootstrap
   CATEGORY:=Administration
   TITLE:=Bootstrap a basic Debian system
   URL:=http://wiki.debian.org/Debootstrap
   CATEGORY:=Administration
   TITLE:=Bootstrap a basic Debian system
   URL:=http://wiki.debian.org/Debootstrap
-  DEPENDS:=+coreutils-chroot +coreutils-sha1sum
-  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
+  DEPENDS:= +coreutils +coreutils-chroot +coreutils-sha1sum
 endef
 
 define Package/debootstrap/description
 endef
 
 define Package/debootstrap/description
@@ -37,7 +36,7 @@ define Package/debootstrap/description
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-# file pkgdetails.c was imported from debian package base-installer version 1.123
+# file pkgdetails.c was imported from debian package base-installer version 1.130
        $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) ./files/pkgdetails.c -o $(PKG_BUILD_DIR)/usr/share/debootstrap/pkgdetails
 endef
 
        $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) ./files/pkgdetails.c -o $(PKG_BUILD_DIR)/usr/share/debootstrap/pkgdetails
 endef
 
@@ -47,6 +46,7 @@ define Package/debootstrap/install
        $(INSTALL_DIR) $(1)/usr/share/debootstrap
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/usr/share/debootstrap/pkgdetails $(1)/usr/share/debootstrap
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/debootstrap/functions $(1)/usr/share/debootstrap
        $(INSTALL_DIR) $(1)/usr/share/debootstrap
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/usr/share/debootstrap/pkgdetails $(1)/usr/share/debootstrap
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/debootstrap/functions $(1)/usr/share/debootstrap
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/debootstrap/devices.tar.gz $(1)/usr/share/debootstrap
        $(INSTALL_DIR) $(1)/usr/share/debootstrap/scripts
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/debootstrap/scripts/* $(1)/usr/share/debootstrap/scripts
 endef
        $(INSTALL_DIR) $(1)/usr/share/debootstrap/scripts
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/debootstrap/scripts/* $(1)/usr/share/debootstrap/scripts
 endef
index 74875a0..4175ee8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/usr/share/debootstrap/functions
 +++ b/usr/share/debootstrap/functions
 --- a/usr/share/debootstrap/functions
 +++ b/usr/share/debootstrap/functions
-@@ -857,8 +857,6 @@ choose_extractor () {
+@@ -838,8 +838,6 @@ choose_extractor () {
  
        if [ -n "$EXTRACTOR_OVERRIDE" ]; then
                extractor="$EXTRACTOR_OVERRIDE"
  
        if [ -n "$EXTRACTOR_OVERRIDE" ]; then
                extractor="$EXTRACTOR_OVERRIDE"