small changes to the way Xorg apps are installed
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Sep 2007 00:16:23 +0000 (00:16 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Sep 2007 00:16:23 +0000 (00:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8897 3c298f89-4303-0410-b956-a3cf2f4a3e73

XOrg/app/common.mk

index a5e4d0d..1c98b14 100644 (file)
@@ -35,9 +35,16 @@ define Build/Configure
        )
 endef
 
-define Package/${PKG_NAME}/install
+define xinit-X11R7.2/install
+       rm -rf $(1)/usr
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xinit $(1)/usr/bin/xinit
+       cd $(1)/usr/bin/; ln -s xinit startx
+endef
+
+define Package/$(PKG_NAME)/install
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)
        rm -rf $(1)/usr/man/
+       $(call $(PKG_NAME)/install,$(1))
 endef
-