[packages] php5: add support for php5 calendar module
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 May 2012 01:12:45 +0000 (01:12 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 May 2012 01:12:45 +0000 (01:12 +0000)
Signed-off-by: Gerald Matzka <mgerald21@yahoo.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31823 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/Makefile

index 0dee647..fdd7a38 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
@@ -20,7 +20,7 @@ PKG_BUILD_PARALLEL:=1
 
 PHP5_MODULES = \
        apc \
-       ctype curl \
+       calendar ctype curl \
        fileinfo \
        dio dom \
        exif \
@@ -56,7 +56,7 @@ define Package/php5/Default
 endef
 
 define Package/php5/Default/description
-  PHP is a widely-used general-purpose scripting language that is especially 
+  PHP is a widely-used general-purpose scripting language that is especially
   suited for Web development and can be embedded into HTML.
 endef
 
@@ -89,7 +89,7 @@ endef
 
 define Package/php5/description
   $(call Package/php5/Default/description)
-  This package contains only the PHP config file. You must actually choose 
+  This package contains only the PHP config file. You must actually choose
   your PHP flavour (cli, cgi or fastcgi).
 endef
 
@@ -159,6 +159,12 @@ else
   CONFIGURE_ARGS+= --disable-apc
 endif
 
+ifneq ($(SDK)$(CONFIG_PACKAGE_php5-mod-calendar),)
+  CONFIGURE_ARGS+= --enable-calendar=shared
+else
+  CONFIGURE_ARGS+= --disable-calendar
+endif
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_php5-mod-ctype),)
   CONFIGURE_ARGS+= --enable-ctype=shared
 else
@@ -521,6 +527,7 @@ $(eval $(call BuildPackage,php5-fastcgi))
 
 #$(eval $(call BuildModule,NAME,TITLE[,PKG DEPENDS]))
 $(eval $(call BuildModule,apc,APC,+PACKAGE_php5-mod-apc:librt))
+$(eval $(call BuildModule,calendar,Calendar))
 $(eval $(call BuildModule,ctype,Ctype))
 $(eval $(call BuildModule,curl,cURL,+PACKAGE_php5-mod-curl:libcurl))
 $(eval $(call BuildModule,fileinfo,Fileinfo,+PACKAGE_php5-mod-fileinfo:libmagic))