[packages] php5: fix paths in php-config, used by pecl module builds
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jan 2013 15:27:49 +0000 (15:27 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jan 2013 15:27:49 +0000 (15:27 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35278 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/php5/Makefile
lang/php5/pecl.mk

index d086223..f7a728c 100644 (file)
@@ -471,6 +471,7 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR_HOST)
        sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
        sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
+       sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR_HOST)/usr\"#" $(STAGING_DIR_HOST)/usr/bin/php-config
 endef
 
 define BuildModule
index ec0f3e2..6bf1928 100644 (file)
@@ -19,6 +19,9 @@ define Build/Configure
        $(Build/Configure/Default)
 endef
 
+CONFIGURE_ARGS+= \
+       --with-php-config=$(STAGING_DIR_HOST)/usr/bin/php-config
+
 define PECLPackage
 
   define Package/php5-pecl-$(1)