fix up downloading in python packages
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2007 15:58:19 +0000 (15:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2007 15:58:19 +0000 (15:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9427 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/egenix-mx/Makefile
lang/kid/Makefile
lang/psycopg/Makefile
lang/pyevent/Makefile
lang/pymysql/Makefile
lang/pypcap/Makefile
lang/pysqlite/Makefile
lang/twisted/Makefile
lang/yapsnmp/Makefile
utils/rdiff-backup/Makefile
utils/rrdtool/Makefile

index 2c9e0b1..3f894ee 100644 (file)
@@ -21,8 +21,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-egenix-mx
index 19aa6ec..139cbad 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-kid
index a1fdb49..a1f3224 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-psycopg
index 63e1fd1..0a48e49 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-event
index 868643b..2375f6f 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-mysql
index 46adf69..ba7933f 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-pcap
index bade7b3..e943119 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-sqlite
index 799e826..6cab302 100644 (file)
@@ -21,8 +21,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/twisted/default
index 851fe9f..8ba8149 100644 (file)
@@ -19,8 +19,8 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifeq ($(DUMP)$(Build/Compile/PyMod),)
-  $(error Python packaging code not found.)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
 endif
 
 define Package/python-yapsnmp
index 74d2c98..537ee20 100644 (file)
@@ -17,7 +17,10 @@ PKG_SOURCE_URL:=http://savannah.nongnu.org/download/rdiff-backup/
 PKG_MD5SUM:=756b38aaf2602d097cafd08996fb7887
 
 include $(INCLUDE_DIR)/package.mk
--include $(TOPDIR)/package/python/python-package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
 
 define PyPackage/rdiff-backup
   SECTION:=utils
index a376aea..25035d9 100644 (file)
@@ -19,7 +19,10 @@ PKG_MD5SUM:=dafa161bc9c61e57636a6085c87c1fe8
 PKG_BUILD_DEPENDS:=libnotimpl python-core
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,./python-package.mk)
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+ifneq ($(MAKECMDGOALS),download)
+  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
+endif
 
 define Package/rrdtool/Default
   SECTION:=utils