postgresql: update to version 9.0.1
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Nov 2010 14:17:24 +0000 (14:17 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Nov 2010 14:17:24 +0000 (14:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24056 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/postgresql/Makefile
libs/postgresql/patches/200-ranlib.patch
libs/postgresql/patches/800-busybox-default-pager.patch

index a534612..7f15de9 100644 (file)
@@ -8,17 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=9.0.0
+PKG_VERSION:=9.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
-       http://ftp7.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
-       http://ftp8.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
-       http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
+       http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=14c2122cc322e69ab2ab702ed7714bbe
+PKG_MD5SUM:=57ba57e43cfe29e16dacbf5789be98d1
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
index 03c16cb..1b68b83 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/port/Makefile
 +++ b/src/port/Makefile
-@@ -49,6 +49,7 @@
+@@ -53,6 +53,7 @@ uninstall:
  
  libpgport.a: $(OBJS)
        $(AR) $(AROPT) $@ $^
index 0605e9f..3cd2532 100644 (file)
@@ -1,8 +1,8 @@
 --- a/src/bin/psql/print.h
 +++ b/src/bin/psql/print.h
-@@ -89,10 +89,6 @@
void          setDecimalLocale(void);
+@@ -171,10 +171,6 @@ extern void printQuery(const PGresult *r
+ extern void setDecimalLocale(void);
extern const printTextFormat *get_line_style(const printTableOpt *opt);
  
 -#ifndef __CYGWIN__
 -#define DEFAULT_PAGER "more"