rename pear packages with a common 'php-' prefix
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2007 18:21:44 +0000 (18:21 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Sep 2007 18:21:44 +0000 (18:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8997 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/pear-db/Makefile [deleted file]
lang/pear-db/patches/100-php5-deprecation-fixes.patch [deleted file]
lang/pear-xmlrpc/Makefile [deleted file]
lang/php-pear-db/Makefile [new file with mode: 0644]
lang/php-pear-db/patches/100-php5-deprecation-fixes.patch [new file with mode: 0644]
lang/php-pear-xmlrpc/Makefile [new file with mode: 0644]

diff --git a/lang/pear-db/Makefile b/lang/pear-db/Makefile
deleted file mode 100644 (file)
index 9c8afb5..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=php-pear-db
-PKG_VERSION:=1.7.11
-PKG_RELEASE:=1
-
-PKG_SOURCE:=DB-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://download.pear.php.net/package
-PKG_MD5SUM:=a57302138757500706e075a4d3d87ef7
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/DB-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/php-pear-db
-  SUBMENU:=PHP
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=PEAR DB module
-  URL:=http://pear.php.net/
-  DEPENDS:=php-pear
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/php-pear-db/install
-       $(INSTALL_DIR) $(1)/usr/lib/php
-       $(CP)   $(PKG_BUILD_DIR)/DB.php $(PKG_BUILD_DIR)/DB \
-               $(1)/usr/lib/php/
-endef
-
-$(eval $(call BuildPackage,php-pear-db))
diff --git a/lang/pear-db/patches/100-php5-deprecation-fixes.patch b/lang/pear-db/patches/100-php5-deprecation-fixes.patch
deleted file mode 100644 (file)
index 714b678..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -ubrN DB-1.7.11-orig/DB/common.php DB-1.7.11/DB/common.php
---- DB-1.7.11-orig/DB/common.php       2007-03-28 02:11:15.000000000 -0500
-+++ DB-1.7.11/DB/common.php    2007-06-11 14:49:37.000000000 -0500
-@@ -1014,7 +1014,7 @@
-         if ($result === DB_OK || DB::isError($result)) {
-             return $result;
-         } else {
--            $tmp =& new DB_result($this, $result);
-+            $tmp = new DB_result($this, $result);
-             return $tmp;
-         }
-     }
-@@ -1217,7 +1217,7 @@
-             if ($result === DB_OK || DB::isError($result)) {
-                 return $result;
-             } else {
--                $tmp =& new DB_result($this, $result);
-+                $tmp = new DB_result($this, $result);
-                 return $tmp;
-             }
-         }
-diff -ubrN DB-1.7.11-orig/DB.php DB-1.7.11/DB.php
---- DB-1.7.11-orig/DB.php      2007-03-28 02:11:15.000000000 -0500
-+++ DB-1.7.11/DB.php   2007-06-11 14:49:42.000000000 -0500
-@@ -591,7 +591,8 @@
-      */
-     function isError($value)
-     {
--        return is_a($value, 'DB_Error');
-+        return $value instanceof DB_Error;
-+        // return is_a($value, 'DB_Error');
-     }
-     // }}}
diff --git a/lang/pear-xmlrpc/Makefile b/lang/pear-xmlrpc/Makefile
deleted file mode 100644 (file)
index 75b6c59..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=php-pear-xmlrpc
-PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=XML_RPC-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://download.pear.php.net/package
-PKG_MD5SUM:=1b516162ad65971b5fd04a7c279627ec
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/XML_RPC-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/php-pear-xmlrpc
-  SUBMENU:=PHP
-  SECTION:=lang
-  CATEGORY:=Languages
-  TITLE:=PEAR XML-RPC module
-  URL:=http://pear.php.net/
-  DEPENDS:=php-pear
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/php-pear-xmlrpc/install
-       $(INSTALL_DIR) $(1)/usr/lib/php/XML
-       $(CP)   $(PKG_BUILD_DIR)/Dump.php \
-               $(PKG_BUILD_DIR)/RPC.php \
-               $(PKG_BUILD_DIR)/Server.php \
-               $(1)/usr/lib/php/XML/
-endef
-
-$(eval $(call BuildPackage,php-pear-xmlrpc))
diff --git a/lang/php-pear-db/Makefile b/lang/php-pear-db/Makefile
new file mode 100644 (file)
index 0000000..9c8afb5
--- /dev/null
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=php-pear-db
+PKG_VERSION:=1.7.11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=DB-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://download.pear.php.net/package
+PKG_MD5SUM:=a57302138757500706e075a4d3d87ef7
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/DB-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/php-pear-db
+  SUBMENU:=PHP
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=PEAR DB module
+  URL:=http://pear.php.net/
+  DEPENDS:=php-pear
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/php-pear-db/install
+       $(INSTALL_DIR) $(1)/usr/lib/php
+       $(CP)   $(PKG_BUILD_DIR)/DB.php $(PKG_BUILD_DIR)/DB \
+               $(1)/usr/lib/php/
+endef
+
+$(eval $(call BuildPackage,php-pear-db))
diff --git a/lang/php-pear-db/patches/100-php5-deprecation-fixes.patch b/lang/php-pear-db/patches/100-php5-deprecation-fixes.patch
new file mode 100644 (file)
index 0000000..714b678
--- /dev/null
@@ -0,0 +1,34 @@
+diff -ubrN DB-1.7.11-orig/DB/common.php DB-1.7.11/DB/common.php
+--- DB-1.7.11-orig/DB/common.php       2007-03-28 02:11:15.000000000 -0500
++++ DB-1.7.11/DB/common.php    2007-06-11 14:49:37.000000000 -0500
+@@ -1014,7 +1014,7 @@
+         if ($result === DB_OK || DB::isError($result)) {
+             return $result;
+         } else {
+-            $tmp =& new DB_result($this, $result);
++            $tmp = new DB_result($this, $result);
+             return $tmp;
+         }
+     }
+@@ -1217,7 +1217,7 @@
+             if ($result === DB_OK || DB::isError($result)) {
+                 return $result;
+             } else {
+-                $tmp =& new DB_result($this, $result);
++                $tmp = new DB_result($this, $result);
+                 return $tmp;
+             }
+         }
+diff -ubrN DB-1.7.11-orig/DB.php DB-1.7.11/DB.php
+--- DB-1.7.11-orig/DB.php      2007-03-28 02:11:15.000000000 -0500
++++ DB-1.7.11/DB.php   2007-06-11 14:49:42.000000000 -0500
+@@ -591,7 +591,8 @@
+      */
+     function isError($value)
+     {
+-        return is_a($value, 'DB_Error');
++        return $value instanceof DB_Error;
++        // return is_a($value, 'DB_Error');
+     }
+     // }}}
diff --git a/lang/php-pear-xmlrpc/Makefile b/lang/php-pear-xmlrpc/Makefile
new file mode 100644 (file)
index 0000000..75b6c59
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=php-pear-xmlrpc
+PKG_VERSION:=1.5.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=XML_RPC-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://download.pear.php.net/package
+PKG_MD5SUM:=1b516162ad65971b5fd04a7c279627ec
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/XML_RPC-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/php-pear-xmlrpc
+  SUBMENU:=PHP
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=PEAR XML-RPC module
+  URL:=http://pear.php.net/
+  DEPENDS:=php-pear
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/php-pear-xmlrpc/install
+       $(INSTALL_DIR) $(1)/usr/lib/php/XML
+       $(CP)   $(PKG_BUILD_DIR)/Dump.php \
+               $(PKG_BUILD_DIR)/RPC.php \
+               $(PKG_BUILD_DIR)/Server.php \
+               $(1)/usr/lib/php/XML/
+endef
+
+$(eval $(call BuildPackage,php-pear-xmlrpc))