Disable ssp support in openssh (#3792)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 13:31:41 +0000 (13:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 13:31:41 +0000 (13:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12011 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openssh/Makefile

index d0d88e5..44437c4 100644 (file)
@@ -29,7 +29,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/openssh-client
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +zlib +libssp
+  DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH client
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
@@ -59,7 +59,7 @@ endef
 define Package/openssh-server
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +zlib +libssp
+  DEPENDS:=+libopenssl +zlib
   TITLE:=OpenSSH server
   URL:=http://www.openssh.com/
   SUBMENU:=SSH
@@ -136,6 +136,7 @@ define Build/Configure
                        --disable-utmpx \
                        --disable-wtmp \
                        --disable-wtmpx \
+                       --without-stackprotect \
                        --without-bsd-auth \
                        --without-kerberos5 \
                        --without-pam \