[packages] obfsproxy: add obfsproxy (#10947)
authorswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Feb 2012 23:09:32 +0000 (23:09 +0000)
committerswalker <swalker@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Feb 2012 23:09:32 +0000 (23:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30430 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/obfsproxy/Makefile [new file with mode: 0644]
net/obfsproxy/patches/001-no-werror.patch [new file with mode: 0644]

diff --git a/net/obfsproxy/Makefile b/net/obfsproxy/Makefile
new file mode 100644 (file)
index 0000000..5b02a75
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=obfsproxy
+PKG_REV:=0ba2d3bbb829cc71e38ecae6d5d9134af9045a22
+PKG_VERSION:=20120210
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://git.torproject.org/obfsproxy.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=git
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/obfsproxy
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
+  TITLE:=A pluggable transports proxy
+  URL:=https://www.torproject.org/projects/obfsproxy
+  DEPENDS:=+libevent2 +libopenssl
+endef
+
+define Package/obfsproxy/description
+  obfsproxy is a tool that attempts to circumvent censorship, by transforming
+  the Tor traffic between the client and the bridge. This way, censors, who
+  usually monitor traffic between the client and the bridge, will see
+  innocent-looking transformed traffic instead of the actual Tor traffic.
+endef
+
+define Package/obfsproxy/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/obfsproxy $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,obfsproxy))
diff --git a/net/obfsproxy/patches/001-no-werror.patch b/net/obfsproxy/patches/001-no-werror.patch
new file mode 100644 (file)
index 0000000..944d522
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,6 @@
+ ACLOCAL_AMFLAGS = -I m4
+-WARNINGS = -Wall -Wwrite-strings -Werror
++WARNINGS = -Wall -Wwrite-strings
+ AM_CPPFLAGS = -I. -I$(srcdir)/src
+ AM_CFLAGS = $(WARNINGS) @libevent_CFLAGS@ @libcrypto_CFLAGS@
+ LDADD = libobfsproxy.a @libevent_LIBS@ @libcrypto_LIBS@ @ws32_LIBS@