[packages] haproxy: forgot to invoke start-stop-daemon with background (-b) mode
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jan 2010 12:32:27 +0000 (12:32 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jan 2010 12:32:27 +0000 (12:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19126 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/haproxy/Makefile
net/haproxy/files/haproxy.init

index 185036c..8e7b509 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
 PKG_VERSION:=1.3.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.3/src/
index fc6b8ff..5e4ef15 100644 (file)
@@ -11,7 +11,7 @@ HAPROXY_PID="/var/run/haproxy.pid"
 start() {
        [ -x "$HAPROXY_BIN" ] || return 1
 
-       start-stop-daemon -S -x $HAPROXY_BIN -- \
+       start-stop-daemon -S -b -x $HAPROXY_BIN -- \
                -f "$HAPROXY_CONFIG" -V -D -d -p "$HAPROXY_PID"
 }