[package] update libtorrent to r1189
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 18:02:09 +0000 (18:02 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 18:02:09 +0000 (18:02 +0000)
This patch upgrades libtorrent and rtorrent to svn version 1189.

Signed-off-by: Luka Perkov < openwrt ->-to->- lukaperkov.net >
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24173 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libtorrent/Makefile
libs/libtorrent/patches/110-fix-no-posix_memalign.diff

index 46c865c..2cf0a1e 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
-PKG_REV:=1165
+PKG_REV:=1189
 PKG_VERSION:=0.12.6_r$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/libtorrent
index e86dd01..d0c1e43 100644 (file)
  
    void construct (pointer p, const T& value) { new((void*)p)T(value); }
    void destroy (pointer p) { p->~T(); }
--  void deallocate (pointer p, size_type num) { ::operator delete((void*)p); }
+-  void deallocate (pointer p, size_type num) { free((void*)p); }
  };
  
  
-@@ -98,6 +94,36 @@ bool operator!= (const cacheline_allocat
+@@ -98,6 +94,36 @@ bool operator!= (const cacheline_allocator<T1>&, const cacheline_allocator<T2>&)
    return false;
  }