[packages] squashfs-tools: fix recursive dependency
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Apr 2013 16:34:09 +0000 (16:34 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Apr 2013 16:34:09 +0000 (16:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@36371 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/squashfs-tools/Config.in
utils/squashfs-tools/Makefile

index 86996e6..1ca3557 100644 (file)
@@ -1,11 +1,11 @@
-if PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs
-
 config SQUASHFS_TOOLS_LZO_SUPPORT
+       depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs
        bool "Enable LZO support"
+       select PACKAGE_liblzo
        default y
 
 config SQUASHFS_TOOLS_XZ_SUPPORT
+       depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs
        bool "Enable XZ support"
+       select PACKAGE_liblzma
        default y
-
-endif
index c3ad0f0..af60e2a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squashfs-tools
 PKG_VERSION:=4.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/squashfs
@@ -26,9 +26,7 @@ define Package/squashfs-tools/Default
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=squashfs-tools
-  DEPENDS += +libpthread +zlib \
-       +SQUASHFS_TOOLS_LZO_SUPPORT:liblzo \
-       +SQUASHFS_TOOLS_XZ_SUPPORT:liblzma
+  DEPENDS += +libpthread +zlib
 endef
 
 define Package/squashfs-tools-mksquashfs