[packages] add transocks - a transparent SOCKS relay proxy
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Feb 2011 23:26:34 +0000 (23:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Feb 2011 23:26:34 +0000 (23:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25781 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/transocks/Makefile [new file with mode: 0644]

diff --git a/net/transocks/Makefile b/net/transocks/Makefile
new file mode 100644 (file)
index 0000000..ba0bde4
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=transocks
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=:pserver:anonymous@transocks.cvs.sourceforge.net:/cvsroot/transocks
+PKG_SOURCE_SUBDIR:=transocks
+PKG_SOURCE_VERSION:=-DNOW
+PKG_SOURCE_PROTO:=cvs
+
+PKG_BUILD_DIR:=transocks
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Compile
+       $(TARGET_CC) \
+               -I$(STAGING_DIR)/usr/include \
+               $(TARGET_CFLAGS) $(TARGET_LDFLAGS) \
+               $(LIBRPC) -lsocks -o \
+               $(PKG_BUILD_DIR)/transocks \
+               $(PKG_BUILD_DIR)/transocks.c
+endef
+
+define Package/transocks
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Transparent SOCKSifying proxy
+  DEPENDS:=+USE_UCLIBC:librpc
+endef
+
+define Package/transocks/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/transocks $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,transocks))