sunxi: add audio module for 4.1
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2015 13:16:11 +0000 (13:16 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Aug 2015 13:16:11 +0000 (13:16 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46704 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/modules.mk

index 0981fe5..3e8f4ba 100644 (file)
@@ -100,3 +100,20 @@ endef
 
 $(eval $(call KernelPackage,wdt-sunxi))
 
+
+define KernelPackage/sound-soc-sunxi
+  TITLE:=AllWinner built-in SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_SUNXI_SOC_CODEC
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/sunxi/sunxi-codec.ko
+  AUTOLOAD:=$(call AutoLoad,65,sunxi-codec)
+  DEPENDS:=@TARGET_sunxi +kmod-sound-soc-core @LINUX_4_1
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-sunxi/description
+  Kernel support for AllWinner built-in SoC audio
+endef
+
+$(eval $(call KernelPackage,sound-soc-sunxi))