[buildroot] move LIB_SUFFIX from base-files to rules.mk
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 14:15:06 +0000 (14:15 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 14:15:06 +0000 (14:15 +0000)
Some packages are going to need fixups based on LIB_SUFFIX

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33080 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
rules.mk

index bb88d5d..441d394 100644 (file)
@@ -23,9 +23,6 @@ ifneq ($(DUMP),1)
   ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
     TARGET:=$(TARGET)-$(PROFILE)
   endif
-  ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
-    LIB_SUFFIX:=64
-  endif
 endif
 
 define Package/base-files
index 114b16c..abb961e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -122,6 +122,10 @@ endif
 LIBRPC=-lrpc
 LIBRPC_DEPENDS=+librpc
 
+ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
+  LIB_SUFFIX:=64
+endif
+
 ifndef DUMP
   ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
     -include $(TOOLCHAIN_DIR)/info.mk