siproxd: fix missing sys/time.h
authorJiri Slachta <slachta@cesnet.cz>
Fri, 18 Jul 2014 19:06:48 +0000 (21:06 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Fri, 18 Jul 2014 19:06:48 +0000 (21:06 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
net/siproxd/Makefile
net/siproxd/patches/011-include-sys-time.patch [new file with mode: 0644]

index 6b08d05..40e7114 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
 PKG_VERSION:=0.8.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
@@ -36,7 +36,7 @@ define Package/siproxd
 endef
 
 define Package/siproxd/description
      Siproxd is a proxy/masquerading daemon for the SIP protocol.
+ Siproxd is a proxy/masquerading daemon for the SIP protocol.
 endef
 
 define Package/siproxd/conffiles
diff --git a/net/siproxd/patches/011-include-sys-time.patch b/net/siproxd/patches/011-include-sys-time.patch
new file mode 100644 (file)
index 0000000..81fabda
--- /dev/null
@@ -0,0 +1,10 @@
+--- siproxd-0.8.1/src/dejitter.c
++++ siproxd-0.8.1/src/dejitter.c
+@@ -24,6 +24,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/time.h>
+ #include <netinet/in.h>
+ #include <osipparser2/osip_parser.h>