asterisk-1.8.x: remove BROKEN mysql module
authorJiri Slachta <slachta@cesnet.cz>
Mon, 11 Aug 2014 08:14:27 +0000 (10:14 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Mon, 11 Aug 2014 08:14:27 +0000 (10:14 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
net/asterisk-1.8.x/Makefile

index 66eb42d..fe7071b 100644 (file)
@@ -187,14 +187,6 @@ else
        --without-libcurl
 endif
 
-ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-mysql),)
-  CONFIGURE_ARGS+= \
-       --with-mysqlclient
-else
-  CONFIGURE_ARGS+= \
-       --without-mysqlclient
-endif
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-pbx-lua),)
   CONFIGURE_ARGS+= \
        --with-lua="$(STAGING_DIR)/usr"
@@ -214,10 +206,10 @@ endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-res-fax-spandsp),)
   CONFIGURE_ARGS+= \
-    --with-spandsp="$(STAGING_DIR)/usr"
+       --with-spandsp="$(STAGING_DIR)/usr"
 else
   CONFIGURE_ARGS+= \
-    --without-spandsp
+       --without-spandsp
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk18-res-srtp),)
@@ -239,6 +231,7 @@ CONFIGURE_ARGS+= \
        --without-gtk2 \
        --without-isdnnet \
        --without-misdn \
+       --without-mysqlclient \
        --without-nbs \
        --with-ncurses="$(STAGING_DIR)/usr" \
        --without-netsnmp \
@@ -367,7 +360,6 @@ $(eval $(call BuildAsterisk18Module,chan-local,Local proxy channel,An implementa
 $(eval $(call BuildAsterisk18Module,chan-mgcp,MGCP channel,the channel chan_mgcp,,/etc/asterisk/mgcp.conf,mgcp.conf,chan_mgcp,))
 $(eval $(call BuildAsterisk18Module,chan-ooh323,ooH323 channel,the channel chan_ooh323,,/etc/asterisk/ooh323.conf,ooh323.conf,chan_ooh323,))
 $(eval $(call BuildAsterisk18Module,chan-skinny,Skinny channel,the channel chan_skinny,,/etc/asterisk/skinny.conf,skinny.conf,chan_skinny,))
-$(eval $(call BuildAsterisk18Module,mysql,MySQL,MySQL support,+libmysqlclient @BROKEN,/etc/asterisk/res_config_mysql.conf,res_config_mysql.conf,res_config_mysql,))
 $(eval $(call BuildAsterisk18Module,odbc,ODBC,ODBC support,+libpthread +libc +unixodbc,/etc/asterisk/cdr_adaptive_odbc.conf /etc/asterisk/cdr_odbc.conf /etc/asterisk/cel_odbc.conf /etc/asterisk/func_odbc.conf /etc/asterisk/res_odbc.conf,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_odbc,cdr_adaptive_odbc cdr_odbc cel_odbc func_odbc res_config_odbc res_odbc,))
 $(eval $(call BuildAsterisk18Module,pgsql,PostgreSQL,PostgreSQL support,+libpq,/etc/asterisk/cel_pgsql.conf /etc/asterisk/cdr_pgsql.conf /etc/asterisk/res_pgsql.conf,cel_pgsql.conf cdr_pgsql.conf res_pgsql.conf,cel_pgsql cdr_pgsql res_config_pgsql,))
 $(eval $(call BuildAsterisk18Module,pbx-ael,Asterisk Extension Logic,support for symbolic Asterisk Extension Logic,,,extensions.ael,pbx_ael,))