FreeSWITCH: Fix issue with Big Endian compilation and sync to FS latest
authorMazilo <openwrt.mazilo@recursor.net>
Tue, 13 Aug 2013 03:42:43 +0000 (23:42 -0400)
committerMazilo <openwrt.mazilo@recursor.net>
Tue, 13 Aug 2013 03:42:43 +0000 (23:42 -0400)
git HEAD.

1. The issue was reported by Berni through trac ticket #13728
(https://dev.openwrt.org/ticket/13728).
2. Updated to FS git HEAD 3ec15cce68852fd4dba7336dd7a7a505d143a111

Signed-off-by: Mazilo <openwrt.mazilo@recursor.net>
net/freeswitch/Makefile

index 614d33f..b3b14cd 100644 (file)
@@ -19,7 +19,7 @@ PKG_VERSION:=1.5.5b
 # http://fisheye.freeswitch.org
 #
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=4eee5aee8c94910f65f47ade4e873aa62e7117eb
+FS_DEFAULT_HEAD:=3ec15cce68852fd4dba7336dd7a7a505d143a111
 FS_LATEST_HEAD:=$(if $(DUMP),$(FS_DEFAULT_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1))
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
@@ -251,7 +251,6 @@ define Package/$(PKG_NAME)/config
     depends on PACKAGE_$(PKG_NAME) && PACKAGE_liblzma
     bool "Enable liblzma usage in libtiff"
     default y
-    #select PACKAGE_liblzma
     help
        Compile libs/tiff package with liblzma support. This option requires
        LZMA2 compression package called liblzma.
@@ -659,6 +658,7 @@ CONFIGURE_VARS+= \
        apr_cv_type_rwlock_t="yes" \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-mod-perl),ac_cv_path_PERL="yes",) \
        libzmq_cv_cxx_werror_flag="" \
+       ac_cv_cflags_warn_all_ansi='-Wall -std=c99 -Wno-unused-variable' \
 
 
 define Build/Prepare