kernel: disable AFS support by default
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 15:15:11 +0000 (15:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 15:15:11 +0000 (15:15 +0000)
This pulls in CONFIG_KEYS, which bloats up the kernel size and is thus
very undesirable. It also currently exposes the kernel to a local root
vulnerability

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Backport of r48364

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48365 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/fs.mk
package/kernel/linux/modules/netsupport.mk

index ca529ff..fa18237 100644 (file)
@@ -29,6 +29,7 @@ $(eval $(call KernelPackage,fs-fscache))
 define KernelPackage/fs-afs
   SUBMENU:=$(FS_MENU)
   TITLE:=Andrew FileSystem client
+  DEFAULT:=n
   DEPENDS:=+kmod-rxrpc +kmod-dnsresolver +kmod-fs-fscache
   KCONFIG:=\
        CONFIG_AFS_FS=m \
index b1899da..cea8e47 100644 (file)
@@ -989,6 +989,7 @@ $(eval $(call KernelPackage,dnsresolver))
 define KernelPackage/rxrpc
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=AF_RXRPC support
+  HIDDEN:=1
   KCONFIG:= \
        CONFIG_AF_RXRPC \
        CONFIG_RXKAD=m \