AA: miniupnpd: merge r35136
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 18:08:44 +0000 (18:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 18:08:44 +0000 (18:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_12.09@35138 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/miniupnpd/Makefile
net/miniupnpd/files/upnpd.config

index dcbc557..6e66186 100644 (file)
@@ -1,27 +1,26 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.6.20110730
-PKG_RELEASE:=6
+PKG_VERSION:=1.7.20121005
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=8bd5c0447b6dc1101b96e958ee67d3ea
+PKG_MD5SUM:=d676ef9516ca3fbdd811aee62f2ca724
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/miniupnpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +libip4tc
+  DEPENDS:=+iptables +libip4tc +IPV6:libip6tc +libnfnetlink
   TITLE:=Lightweight UPnP daemon
   SUBMENU:=Firewall
   URL:=http://miniupnp.free.fr/
@@ -32,17 +31,18 @@ define Package/miniupnpd/conffiles
 /etc/config/upnpd
 endef
 
-define Build/Compile
-       echo "OpenWRT/$(OPENWRTVERSION)" | tr \(\)\  _ >$(PKG_BUILD_DIR)/os.openwrt
-       $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.linux \
-               $(TARGET_CONFIGURE_OPTS) \
-               STAGING_DIR="$(STAGING_DIR)" \
-               CC="$(TARGET_CC)" \
-               TARGET_OPENWRT=1 \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(firstword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/include)) -DIPTABLES_143" \
-               LIBS="$(STAGING_DIR)/usr/lib/libip4tc.so"
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       echo "OpenWrt/$(OPENWRTVERSION)" | tr \(\)\  _ >$(PKG_BUILD_DIR)/os.openwrt
 endef
 
+MAKE_FLAGS += \
+       LIBS="" \
+       CC="$(TARGET_CC) -DIPTABLES_143 -lnfnetlink -lip4tc $(if $(CONFIG_IPV6),-lip6tc)" \
+       CONFIG_OPTIONS="$(if $(CONFIG_IPV6),--ipv6) --leasefile" \
+       -f Makefile.linux \
+       miniupnpd
+
 define Package/miniupnpd/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/hotplug.d/iface $(1)/etc/hotplug.d/firewall
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/miniupnpd $(1)/usr/sbin/miniupnpd
index 02b4b2a..002e207 100644 (file)
@@ -8,6 +8,7 @@ config upnpd config
        option external_iface   wan
        option internal_iface   lan
        option port             5000
+       option upnp_lease_file  /var/upnp.leases
        
 config perm_rule
        option action           allow