AA: iptables: backport r36867 (#13653)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jun 2013 14:05:23 +0000 (14:05 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Jun 2013 14:05:23 +0000 (14:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@36869 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile

index 45a1c87..e36a093 100644 (file)
@@ -387,6 +387,10 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/
+
+       # XXX: needed by firewall3
+       $(INSTALL_DIR) $(1)/usr/lib/iptables
+       $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
 endef
 
 define Package/iptables/install