AA: kernel: refresh patches
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 22:24:10 +0000 (22:24 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jul 2013 22:24:10 +0000 (22:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@37262 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/patches-3.3/065-8139cp-fixes.patch
target/linux/generic/patches-3.3/080-prot-release-cb.patch
target/linux/generic/patches-3.3/605-netfilter_conntrack_flush.patch
target/linux/generic/patches-3.3/660-ipv6-loopback-policy-routing.patch
target/linux/generic/patches-3.3/665-ipv6-fix-handling-of-blackhole-and-prohibit-routes.patch
target/linux/generic/patches-3.3/668-ipv6-fix-handling-of-throw-routes.patch
target/linux/generic/patches-3.3/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.3/729-phy-tantos.patch

index 33ca1a1..77c903c 100644 (file)
@@ -66,11 +66,9 @@ Date:   Sun Nov 25 15:52:09 2012 -0500
     
     Signed-off-by: David S. Miller <davem@davemloft.net>
 
-diff --git a/drivers/net/ethernet/realtek/8139cp.c b/drivers/net/ethernet/realtek/8139cp.c
-index b01f83a..6cb96b4 100644
 --- a/drivers/net/ethernet/realtek/8139cp.c
 +++ b/drivers/net/ethernet/realtek/8139cp.c
-@@ -648,6 +648,7 @@ static void cp_tx (struct cp_private *cp)
+@@ -645,6 +645,7 @@ static void cp_tx (struct cp_private *cp
  {
        unsigned tx_head = cp->tx_head;
        unsigned tx_tail = cp->tx_tail;
@@ -78,7 +76,7 @@ index b01f83a..6cb96b4 100644
  
        while (tx_tail != tx_head) {
                struct cp_desc *txd = cp->tx_ring + tx_tail;
-@@ -666,6 +667,9 @@ static void cp_tx (struct cp_private *cp)
+@@ -663,6 +664,9 @@ static void cp_tx (struct cp_private *cp
                                 le32_to_cpu(txd->opts1) & 0xffff,
                                 PCI_DMA_TODEVICE);
  
@@ -88,7 +86,7 @@ index b01f83a..6cb96b4 100644
                if (status & LastFrag) {
                        if (status & (TxError | TxFIFOUnder)) {
                                netif_dbg(cp, tx_err, cp->dev,
-@@ -697,6 +701,7 @@ static void cp_tx (struct cp_private *cp)
+@@ -694,6 +698,7 @@ static void cp_tx (struct cp_private *cp
  
        cp->tx_tail = tx_tail;
  
@@ -96,7 +94,7 @@ index b01f83a..6cb96b4 100644
        if (TX_BUFFS_AVAIL(cp) > (MAX_SKB_FRAGS + 1))
                netif_wake_queue(cp->dev);
  }
-@@ -843,6 +848,8 @@ static netdev_tx_t cp_start_xmit (struct sk_buff *skb,
+@@ -840,6 +845,8 @@ static netdev_tx_t cp_start_xmit (struct
                wmb();
        }
        cp->tx_head = entry;
@@ -105,7 +103,7 @@ index b01f83a..6cb96b4 100644
        netif_dbg(cp, tx_queued, cp->dev, "tx queued, slot %d, skblen %d\n",
                  entry, skb->len);
        if (TX_BUFFS_AVAIL(cp) <= (MAX_SKB_FRAGS + 1))
-@@ -937,6 +944,8 @@ static void cp_stop_hw (struct cp_private *cp)
+@@ -934,6 +941,8 @@ static void cp_stop_hw (struct cp_privat
  
        cp->rx_tail = 0;
        cp->tx_head = cp->tx_tail = 0;
@@ -114,7 +112,7 @@ index b01f83a..6cb96b4 100644
  }
  
  static void cp_reset_hw (struct cp_private *cp)
-@@ -957,8 +966,38 @@ static void cp_reset_hw (struct cp_private *cp)
+@@ -954,8 +963,38 @@ static void cp_reset_hw (struct cp_priva
  
  static inline void cp_start_hw (struct cp_private *cp)
  {
@@ -153,7 +151,7 @@ index b01f83a..6cb96b4 100644
  }
  
  static void cp_enable_irq(struct cp_private *cp)
-@@ -969,7 +1008,6 @@ static void cp_enable_irq(struct cp_private *cp)
+@@ -966,7 +1005,6 @@ static void cp_enable_irq(struct cp_priv
  static void cp_init_hw (struct cp_private *cp)
  {
        struct net_device *dev = cp->dev;
@@ -161,7 +159,7 @@ index b01f83a..6cb96b4 100644
  
        cp_reset_hw(cp);
  
-@@ -992,17 +1030,6 @@ static void cp_init_hw (struct cp_private *cp)
+@@ -989,17 +1027,6 @@ static void cp_init_hw (struct cp_privat
  
        cpw8(Config5, cpr8(Config5) & PMEStatus);
  
@@ -179,7 +177,7 @@ index b01f83a..6cb96b4 100644
        cpw16(MultiIntr, 0);
  
        cpw8_f(Cfg9346, Cfg9346_Lock);
-@@ -1192,6 +1219,7 @@ static void cp_tx_timeout(struct net_device *dev)
+@@ -1188,6 +1215,7 @@ static void cp_tx_timeout(struct net_dev
        cp_clean_rings(cp);
        rc = cp_init_rings(cp);
        cp_start_hw(cp);
index 8af8a19..56cda6b 100644 (file)
@@ -3,8 +3,8 @@ TCP Small Queues) but we need it for pppoatm too.
 
 --- a/include/net/sock.h
 +++ b/include/net/sock.h
-@@ -858,6 +858,8 @@ struct proto {
-       int                     (*backlog_rcv) (struct sock *sk,
+@@ -810,6 +810,8 @@ struct proto {
+       int                     (*backlog_rcv) (struct sock *sk, 
                                                struct sk_buff *skb);
  
 +      void            (*release_cb)(struct sock *sk);
@@ -14,7 +14,7 @@ TCP Small Queues) but we need it for pppoatm too.
        void                    (*unhash)(struct sock *sk);
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2159,6 +2159,10 @@ void release_sock(struct sock *sk)
+@@ -2138,6 +2138,10 @@ void release_sock(struct sock *sk)
        spin_lock_bh(&sk->sk_lock.slock);
        if (sk->sk_backlog.tail)
                __release_sock(sk);
index cbcd29a..3ee5e49 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -267,10 +267,34 @@ static int ct_open(struct inode *inode, 
+@@ -267,10 +267,34 @@ static int ct_open(struct inode *inode,
                        sizeof(struct ct_iter_state));
  }
  
index 48af3d3..a24bc53 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/ipv6/route.c
 +++ b/net/ipv6/route.c
-@@ -937,6 +937,8 @@ struct dst_entry * ip6_route_output(struct net *net, const struct sock *sk,
+@@ -899,6 +899,8 @@ struct dst_entry * ip6_route_output(stru
  {
        int flags = 0;
  
index b744479..61a4fe4 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.3.8/include/net/ip6_fib.h
-===================================================================
---- linux-3.3.8.orig/include/net/ip6_fib.h     2013-06-10 20:53:49.093355283 +0200
-+++ linux-3.3.8/include/net/ip6_fib.h  2013-06-10 20:53:49.085355283 +0200
-@@ -37,6 +37,7 @@
+--- a/include/net/ip6_fib.h
++++ b/include/net/ip6_fib.h
+@@ -37,6 +37,7 @@ struct fib6_config {
        int             fc_ifindex;
        u32             fc_flags;
        u32             fc_protocol;
@@ -10,11 +8,9 @@ Index: linux-3.3.8/include/net/ip6_fib.h
  
        struct in6_addr fc_dst;
        struct in6_addr fc_src;
-Index: linux-3.3.8/net/ipv6/route.c
-===================================================================
---- linux-3.3.8.orig/net/ipv6/route.c  2013-06-10 20:53:49.093355283 +0200
-+++ linux-3.3.8/net/ipv6/route.c       2013-06-10 20:53:49.089355283 +0200
-@@ -1333,8 +1333,18 @@
+--- a/net/ipv6/route.c
++++ b/net/ipv6/route.c
+@@ -1333,8 +1333,18 @@ int ip6_route_add(struct fib6_config *cf
                }
                rt->dst.output = ip6_pkt_discard_out;
                rt->dst.input = ip6_pkt_discard;
@@ -34,7 +30,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                goto install_route;
        }
  
-@@ -2265,8 +2275,11 @@
+@@ -2265,8 +2275,11 @@ static int rtm_to_fib6_config(struct sk_
        cfg->fc_src_len = rtm->rtm_src_len;
        cfg->fc_flags = RTF_UP;
        cfg->fc_protocol = rtm->rtm_protocol;
@@ -47,7 +43,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2396,8 +2409,19 @@
+@@ -2396,8 +2409,19 @@ static int rt6_fill_node(struct net *net
                table = RT6_TABLE_UNSPEC;
        rtm->rtm_table = table;
        NLA_PUT_U32(skb, RTA_TABLE, table);
index f8d6053..b9c01ec 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.3.8/net/ipv6/route.c
-===================================================================
---- linux-3.3.8.orig/net/ipv6/route.c  2013-06-10 20:53:54.233355405 +0200
-+++ linux-3.3.8/net/ipv6/route.c       2013-06-10 20:53:54.225355405 +0200
-@@ -1341,6 +1341,9 @@
+--- a/net/ipv6/route.c
++++ b/net/ipv6/route.c
+@@ -1341,6 +1341,9 @@ int ip6_route_add(struct fib6_config *cf
                case RTN_PROHIBIT:
                        rt->dst.error = -EACCES;
                        break;
@@ -12,7 +10,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                default:
                        rt->dst.error = -ENETUNREACH;
                        break;
-@@ -2279,7 +2282,8 @@
+@@ -2279,7 +2282,8 @@ static int rtm_to_fib6_config(struct sk_
  
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
@@ -22,7 +20,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2417,6 +2421,9 @@
+@@ -2417,6 +2421,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
index 1092951..6162774 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.3.8/include/net/netns/ipv6.h
-===================================================================
---- linux-3.3.8.orig/include/net/netns/ipv6.h  2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/include/net/netns/ipv6.h       2013-06-10 20:53:57.621355486 +0200
-@@ -50,6 +50,7 @@
+--- a/include/net/netns/ipv6.h
++++ b/include/net/netns/ipv6.h
+@@ -50,6 +50,7 @@ struct netns_ipv6 {
        unsigned long            ip6_rt_last_gc;
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        struct rt6_info         *ip6_prohibit_entry;
@@ -10,11 +8,9 @@ Index: linux-3.3.8/include/net/netns/ipv6.h
        struct rt6_info         *ip6_blk_hole_entry;
        struct fib6_table       *fib6_local_tbl;
        struct fib_rules_ops    *fib6_rules_ops;
-Index: linux-3.3.8/include/linux/fib_rules.h
-===================================================================
---- linux-3.3.8.orig/include/linux/fib_rules.h 2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/include/linux/fib_rules.h      2013-06-10 20:53:57.621355486 +0200
-@@ -64,6 +64,10 @@
+--- a/include/linux/fib_rules.h
++++ b/include/linux/fib_rules.h
+@@ -64,6 +64,10 @@ enum {
        FR_ACT_BLACKHOLE,       /* Drop without notification */
        FR_ACT_UNREACHABLE,     /* Drop with ENETUNREACH */
        FR_ACT_PROHIBIT,        /* Drop with EACCES */
@@ -25,11 +21,9 @@ Index: linux-3.3.8/include/linux/fib_rules.h
        __FR_ACT_MAX,
  };
  
-Index: linux-3.3.8/include/linux/icmpv6.h
-===================================================================
---- linux-3.3.8.orig/include/linux/icmpv6.h    2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/include/linux/icmpv6.h 2013-06-10 20:53:57.621355486 +0200
-@@ -123,6 +123,7 @@
+--- a/include/linux/icmpv6.h
++++ b/include/linux/icmpv6.h
+@@ -123,6 +123,7 @@ static inline struct icmp6hdr *icmp6_hdr
  #define ICMPV6_NOT_NEIGHBOUR          2
  #define ICMPV6_ADDR_UNREACH           3
  #define ICMPV6_PORT_UNREACH           4
@@ -37,11 +31,9 @@ Index: linux-3.3.8/include/linux/icmpv6.h
  
  /*
   *    Codes for Time Exceeded
-Index: linux-3.3.8/include/linux/rtnetlink.h
-===================================================================
---- linux-3.3.8.orig/include/linux/rtnetlink.h 2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/include/linux/rtnetlink.h      2013-06-10 20:53:57.621355486 +0200
-@@ -191,6 +191,7 @@
+--- a/include/linux/rtnetlink.h
++++ b/include/linux/rtnetlink.h
+@@ -191,6 +191,7 @@ enum {
        RTN_THROW,              /* Not in this table            */
        RTN_NAT,                /* Translate this address       */
        RTN_XRESOLVE,           /* Use external resolver        */
@@ -49,11 +41,9 @@ Index: linux-3.3.8/include/linux/rtnetlink.h
        __RTN_MAX
  };
  
-Index: linux-3.3.8/net/ipv4/fib_rules.c
-===================================================================
---- linux-3.3.8.orig/net/ipv4/fib_rules.c      2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv4/fib_rules.c   2013-06-10 20:53:57.621355486 +0200
-@@ -87,6 +87,10 @@
+--- a/net/ipv4/fib_rules.c
++++ b/net/ipv4/fib_rules.c
+@@ -87,6 +87,10 @@ static int fib4_rule_action(struct fib_r
                err = -EACCES;
                goto errout;
  
@@ -64,11 +54,9 @@ Index: linux-3.3.8/net/ipv4/fib_rules.c
        case FR_ACT_BLACKHOLE:
        default:
                err = -EINVAL;
-Index: linux-3.3.8/net/ipv4/fib_semantics.c
-===================================================================
---- linux-3.3.8.orig/net/ipv4/fib_semantics.c  2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv4/fib_semantics.c       2013-06-10 20:53:57.621355486 +0200
-@@ -139,6 +139,10 @@
+--- a/net/ipv4/fib_semantics.c
++++ b/net/ipv4/fib_semantics.c
+@@ -139,6 +139,10 @@ const struct fib_prop fib_props[RTN_MAX
                .error  = -EINVAL,
                .scope  = RT_SCOPE_NOWHERE,
        },
@@ -79,11 +67,9 @@ Index: linux-3.3.8/net/ipv4/fib_semantics.c
  };
  
  /* Release a nexthop info record */
-Index: linux-3.3.8/net/ipv4/fib_trie.c
-===================================================================
---- linux-3.3.8.orig/net/ipv4/fib_trie.c       2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv4/fib_trie.c    2013-06-10 20:53:57.625355486 +0200
-@@ -2349,6 +2349,7 @@
+--- a/net/ipv4/fib_trie.c
++++ b/net/ipv4/fib_trie.c
+@@ -2349,6 +2349,7 @@ static const char *const rtn_type_names[
        [RTN_THROW] = "THROW",
        [RTN_NAT] = "NAT",
        [RTN_XRESOLVE] = "XRESOLVE",
@@ -91,11 +77,9 @@ Index: linux-3.3.8/net/ipv4/fib_trie.c
  };
  
  static inline const char *rtn_type(char *buf, size_t len, unsigned int t)
-Index: linux-3.3.8/net/ipv4/ipmr.c
-===================================================================
---- linux-3.3.8.orig/net/ipv4/ipmr.c   2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv4/ipmr.c        2013-06-10 20:53:57.625355486 +0200
-@@ -176,6 +176,7 @@
+--- a/net/ipv4/ipmr.c
++++ b/net/ipv4/ipmr.c
+@@ -176,6 +176,7 @@ static int ipmr_rule_action(struct fib_r
        case FR_ACT_UNREACHABLE:
                return -ENETUNREACH;
        case FR_ACT_PROHIBIT:
@@ -103,11 +87,9 @@ Index: linux-3.3.8/net/ipv4/ipmr.c
                return -EACCES;
        case FR_ACT_BLACKHOLE:
        default:
-Index: linux-3.3.8/net/ipv6/fib6_rules.c
-===================================================================
---- linux-3.3.8.orig/net/ipv6/fib6_rules.c     2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv6/fib6_rules.c  2013-06-10 20:53:57.625355486 +0200
-@@ -70,6 +70,9 @@
+--- a/net/ipv6/fib6_rules.c
++++ b/net/ipv6/fib6_rules.c
+@@ -70,6 +70,9 @@ static int fib6_rule_action(struct fib_r
        case FR_ACT_PROHIBIT:
                rt = net->ipv6.ip6_prohibit_entry;
                goto discard_pkt;
@@ -117,11 +99,9 @@ Index: linux-3.3.8/net/ipv6/fib6_rules.c
        }
  
        table = fib6_get_table(net, rule->table);
-Index: linux-3.3.8/net/ipv6/ip6mr.c
-===================================================================
---- linux-3.3.8.orig/net/ipv6/ip6mr.c  2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv6/ip6mr.c       2013-06-10 20:53:57.629355486 +0200
-@@ -164,6 +164,8 @@
+--- a/net/ipv6/ip6mr.c
++++ b/net/ipv6/ip6mr.c
+@@ -164,6 +164,8 @@ static int ip6mr_rule_action(struct fib_
                return -ENETUNREACH;
        case FR_ACT_PROHIBIT:
                return -EACCES;
@@ -130,11 +110,9 @@ Index: linux-3.3.8/net/ipv6/ip6mr.c
        case FR_ACT_BLACKHOLE:
        default:
                return -EINVAL;
-Index: linux-3.3.8/net/ipv6/route.c
-===================================================================
---- linux-3.3.8.orig/net/ipv6/route.c  2013-06-10 20:53:57.637355486 +0200
-+++ linux-3.3.8/net/ipv6/route.c       2013-06-10 20:53:57.629355486 +0200
-@@ -228,6 +228,24 @@
+--- a/net/ipv6/route.c
++++ b/net/ipv6/route.c
+@@ -228,6 +228,24 @@ static struct rt6_info ip6_prohibit_entr
        .rt6i_ref       = ATOMIC_INIT(1),
  };
  
@@ -159,7 +137,7 @@ Index: linux-3.3.8/net/ipv6/route.c
  static struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1344,6 +1362,9 @@
+@@ -1344,6 +1362,9 @@ int ip6_route_add(struct fib6_config *cf
                case RTN_THROW:
                        rt->dst.error = -EAGAIN;
                        break;
@@ -169,7 +147,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                default:
                        rt->dst.error = -ENETUNREACH;
                        break;
-@@ -2068,6 +2089,17 @@
+@@ -2068,6 +2089,17 @@ static int ip6_pkt_prohibit_out(struct s
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -187,7 +165,7 @@ Index: linux-3.3.8/net/ipv6/route.c
  #endif
  
  /*
-@@ -2283,7 +2315,8 @@
+@@ -2283,7 +2315,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
@@ -197,7 +175,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2421,6 +2454,9 @@
+@@ -2421,6 +2454,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
@@ -207,7 +185,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -2665,6 +2701,8 @@
+@@ -2665,6 +2701,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -216,7 +194,7 @@ Index: linux-3.3.8/net/ipv6/route.c
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -2925,6 +2963,17 @@
+@@ -2925,6 +2963,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -234,7 +212,7 @@ Index: linux-3.3.8/net/ipv6/route.c
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -2947,6 +2996,8 @@
+@@ -2947,6 +2996,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -243,7 +221,7 @@ Index: linux-3.3.8/net/ipv6/route.c
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -2968,6 +3019,7 @@
+@@ -2968,6 +3019,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -251,7 +229,7 @@ Index: linux-3.3.8/net/ipv6/route.c
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3013,6 +3065,9 @@
+@@ -3013,6 +3065,9 @@ int __init ip6_route_init(void)
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 0466d94..99a4e71 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -206,3 +206,8 @@ endif # PHYLIB
+@@ -210,3 +210,8 @@ endif # PHYLIB
  config MICREL_KS8995MA
        tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
        depends on SPI
@@ -11,8 +11,8 @@
 +      select ETHERNET_PACKET_MANGLE
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY)  += rtl8366rb
- obj-$(CONFIG_RTL8367_PHY)     += rtl8367.o
+@@ -29,6 +29,7 @@ obj-$(CONFIG_RTL8367_PHY)    += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY)    += rtl8367b.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_MICREL_PHY)      += micrel.o
 +obj-$(CONFIG_PSB6970_PHY)     += psb6970.o