[packages_10.03.2] aprx: merge r29048, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 14:59:06 +0000 (14:59 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 14:59:06 +0000 (14:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30191 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/aprx/Makefile
net/aprx/files/aprx.init

index 6a38e75..16e98ba 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=aprx
 PKG_REV:=421
 PKG_VERSION:=2.00_r$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://repo.ham.fi/svn/aprx/trunk/
@@ -45,4 +45,8 @@ define Package/aprx/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/aprx-stat $(1)/usr/sbin/
 endef
 
+define Package/aprx/conffiles
+/etc/aprx.conf
+endef
+
 $(eval $(call BuildPackage,aprx))
index e2dcd89..9682eee 100644 (file)
@@ -1,23 +1,15 @@
 #!/bin/sh /etc/rc.common
-#Init script for aprx
+# Copyright (C) 2008-2011 OpenWrt.org
 
 START=99
-APRX_BIN="/usr/sbin/aprx"
-APRX_LOG_DIR="/var/log/aprx"
-
-system_config() {
-       local cfg="$1"
-
-       config_get hostname "$cfg" hostname
-}
 
+SERVICE_USE_PID=1
 
 start() {
-       [ -x "$APRX_BIN" ] || return 1
-       [ -d "$APRX_LOG_DIR" ] || mkdir -p $APRX_LOG_DIR
-       $APRX_BIN
-       }
+       mkdir -m 0755 -p /var/log/aprx
+       service_start /usr/sbin/aprx
+}
 
 stop() {
-       killall aprx
+       service_stop /usr/sbin/aprx
 }