[packages_10.03.2] rp-l2tp: merge r29049, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:03:44 +0000 (16:03 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:03:44 +0000 (16:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30252 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/rp-l2tp/Makefile
net/rp-l2tp/files/rp-l2tpd.init

index d120c34..d7942fa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rp-l2tp
@@ -34,7 +34,7 @@ endef
 
 TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/libevent $(TARGET_CFLAGS)
 
-define Package/rp-l2tpd/install        
+define Package/rp-l2tpd/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tp.conf.example $(1)/etc/l2tp.conf
        $(INSTALL_DIR) $(1)/usr/lib/l2tp
@@ -47,7 +47,11 @@ define Package/rp-l2tpd/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/l2tp-control $(1)/usr/sbin/
 endef
 
-#define Package/rp-l2tpd-mod-cmd/install       
+define Package/rp-l2tpd/conffiles
+/etc/l2tp.conf
+endef
+
+#define Package/rp-l2tpd-mod-cmd/install
 #      $(INSTALL_DIR) $(1)/usr/lib/l2tp
 #      $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tp/cmd.so $(1)/usr/lib/l2tp/
 #      $(INSTALL_DIR) $(1)/usr/sbin
index 4895e17..cff1f15 100644 (file)
@@ -1,17 +1,13 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=60
-DEFAULT=/etc/default/rp-l2tpd
-RUN_D=/var/run
-[ -f $DEFAULT ] && . $DEFAULT
 
 start() {
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       l2tpd $OPTIONS
+       service_start /usr/sbin/l2tpd
 }
 
 stop() {
-       killall l2tpd
+       service_stop /usr/sbin/l2tpd
 }