[packages_10.03.2] mpdas: merge r27709, r27710, r28969
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:38:10 +0000 (16:38 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:38:10 +0000 (16:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30284 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/mpdas/Makefile
sound/mpdas/files/mpdas.init
sound/mpdas/patches/001-flags.patch

index 2550ceb..b0b1f1f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpdas
 PKG_VERSION:=0.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://50hz.ws/mpdas
@@ -28,7 +28,7 @@ endef
 
 define Package/mpdas/description
     mpdas is an AudioScrobbler client for MPD written in C++.
-    It supports the latest AudioScrobbler protocol (1.21).
+    It supports the latest AudioScrobbler protocol (2.0).
     In case of a downtime or connectivity problems, mpdas will 
     cache the played songs to ~/.mpdascache.
 endef
index 4b8eeb6..ba64d95 100644 (file)
@@ -1,11 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
+
 START=94
 
+SERVICE_DAEMONIZE=1
+
 start() {
-       HOME=/root /usr/bin/mpdas -c /etc/mpdasrc &
+       HOME=/root \
+       service_start /usr/bin/mpdas -c /etc/mpdasrc
 }
 
 stop() {
-       killall mpdas
+       service_stop /usr/bin/mpdas
 }
index f136683..11a6a6d 100644 (file)
@@ -1,12 +1,19 @@
---- a/Makefile
-+++ b/Makefile
-@@ -7,8 +7,8 @@ PREFIX = /usr/local
- MANPREFIX = ${PREFIX}/man/man1
- CONFIG = $(PREFIX)/etc
+Index: mpdas-0.3.0/Makefile
+===================================================================
+--- mpdas-0.3.0.orig/Makefile  2010-11-22 02:15:12.000000000 +0100
++++ mpdas-0.3.0/Makefile       2011-07-20 16:53:31.000000000 +0200
+@@ -3,12 +3,12 @@
+ CXX   ?= g++
+ OBJ   = main.o md5.o utils.o mpd.o audioscrobbler.o cache.o config.o
+ OUT   = mpdas
+-PREFIX ?= /usr/local
++PREFIX ?= /
+ MANPREFIX ?= ${PREFIX}/man/man1
+ CONFIG ?= $(PREFIX)/etc
  
 -CXXFLAGS      += `pkg-config --cflags libmpd libcurl` 
 -LIBS          = `pkg-config --libs libmpd libcurl`
-+CXXFLAGS      += $(CPPFLAGS) `pkg-config --cflags libmpd libcurl` 
++CXXFLAGS      += $(CPPFLAGS) `pkg-config --cflags libmpd libcurl`
 +LIBS          = $(LDFLAGS) `pkg-config --libs libmpd libcurl`
  
  CXXFLAGS      += -DCONFDIR="\"$(CONFIG)\"" -DVERSION="\"$(VERSION)\""