[packages_10.03.2] dbus: merge r28015, r28027, r28947
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:46:45 +0000 (16:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:46:45 +0000 (16:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30292 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/dbus/Makefile
utils/dbus/files/dbus.init
utils/dbus/patches/002-no_wno_pointer_sign.patch [deleted file]
utils/dbus/patches/01-dbus-nopie-fix.patch [deleted file]

index eec787d..b275c21 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 
 # Make sure to also update the dbus-x package
 PKG_NAME:=dbus
-PKG_VERSION:=1.2.4.6permissive
+PKG_VERSION:=1.4.14
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
-PKG_MD5SUM:=1a158fe326b078d1377a977121888496
+PKG_MD5SUM:=ae6de2562a57516cfabaf56903375ba9
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -54,7 +54,7 @@ endef
 define Package/dbus
 $(call Package/dbus/Default)
  TITLE+= (daemon)
- DEPENDS:= +libexpat +libdbus
+ DEPENDS:= +libexpat +libdbus +librt
 endef
 
 define Package/dbus/Description
@@ -87,7 +87,7 @@ CONFIGURE_ARGS += \
        --disable-asserts \
        --disable-console-owner-file \
        --disable-doxygen-docs \
-       --disable-gcov \
+       --disable-compiler_coverage \
        --disable-selinux \
        --disable-tests \
        --disable-verbose-mode \
index 1c622fc..4294083 100644 (file)
@@ -1,27 +1,17 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2008 OpenWrt.org
-
-SSD=start-stop-daemon
-PIDF=/var/run/dbus.pid
-PROG=/usr/sbin/dbus-daemon
-ARGS=--system
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=60
-start() {
-       if [ -x /usr/bin/dbus-uuidgen ]; then
-               mkdir -p /var/lib/dbus/
-               /usr/bin/dbus-uuidgen --ensure
-       fi
 
-       mkdir -p /var/run/dbus
-       $SSD -S -p $PIDF -q -x $PROG -- $ARGS
-}
+SERVICE_PID_FILE=/var/run/dbus.pid
 
-stop() {
-       $SSD -K -p $PIDF -q
+start() {
+       mkdir -m 0755 -p /var/lib/dbus
+       mkdir -m 0755 -p /var/run/dbus
+       [ -x /usr/bin/dbus-uuidgen ] && /usr/bin/dbus-uuidgen --ensure
+       service_start /usr/sbin/dbus-daemon --system
 }
 
-status() {
-       ps | grep -q "^ *$(cat $PIDF 2>/dev/null) *.*$PROG"
+stop() {
+       service_stop /usr/sbin/dbus-daemon && rm $SERVICE_PID_FILE
 }
-
diff --git a/utils/dbus/patches/002-no_wno_pointer_sign.patch b/utils/dbus/patches/002-no_wno_pointer_sign.patch
deleted file mode 100644 (file)
index ba69855..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN dbus-1.2.4.6permissive/configure dbus-1.2.4.6permissive.new/configure
---- dbus-1.2.4.6permissive/configure   2009-05-06 19:35:38.000000000 +0200
-+++ dbus-1.2.4.6permissive.new/configure       2010-03-26 17:40:13.000000000 +0100
-@@ -20958,7 +20958,7 @@
-   esac
-   case " $CFLAGS " in
-   *[\ \       ]-Wno-pointer-sign[\ \  ]*) ;;
--  *) CFLAGS="$CFLAGS -Wno-pointer-sign" ;;
-+  *) CFLAGS="$CFLAGS" ;;
-   esac
-   # http://bugs.freedesktop.org/show_bug.cgi?id=19195
diff --git a/utils/dbus/patches/01-dbus-nopie-fix.patch b/utils/dbus/patches/01-dbus-nopie-fix.patch
deleted file mode 100644 (file)
index c6142a3..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -20927,19 +20927,6 @@ if test "x$GCC" = "xyes"; then
-      ;;
-   esac
--  case " $CFLAGS " in
--  *[\ \       ]-fPIE[\ \      ]*) ;;
--  *) if cc_supports_flag -fPIE; then
--        PIE_CFLAGS="-fPIE"
--        if ld_supports_flag -z,relro; then
--           PIE_LDFLAGS="-pie -Wl,-z,relro"
--        else
--           PIE_LDFLAGS="-pie"
--        fi
--     fi
--     ;;
--  esac
--
-   ### Disabled warnings, and compiler flag overrides
-   # Let's just ignore unused for now