ar71xx: backport tl-wr740n support from r24811 (#9843)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jul 2011 21:57:28 +0000 (21:57 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jul 2011 21:57:28 +0000 (21:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27841 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk
tools/firmware-utils/src/mktplinkfw.c

index b436003..f39be3c 100644 (file)
@@ -497,6 +497,10 @@ define Image/Build/Profile/TLWR741NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
 
+define Image/Build/Profile/TLWR740NV1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
 endef
@@ -563,6 +567,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
+       $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
index 7efb1a3..ba08ee4 100644 (file)
@@ -16,6 +16,18 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+
+define Profile/TLWR740NV1
+    NAME:=TP-LINK TL-WR740N v1
+    PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+    Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
        PACKAGES:=kmod-ath9k wpad-mini
index cfb03f8..4db4bc0 100644 (file)
@@ -34,6 +34,7 @@
 
 #define HEADER_VERSION_V1      0x01000000
 #define HWID_TL_WR741ND_V1     0x07410001
+#define HWID_TL_WR740N_V1      0x07400001
 #define HWID_TL_WR841N_V1_5    0x08410002
 #define HWID_TL_WR841ND_V3     0x08410003
 #define HWID_TL_WR841ND_V5     0x08410005
@@ -117,6 +118,14 @@ static struct board_info boards[] = {
                .kernel_ep      = 0x80060000,
                .rootfs_ofs     = 0x140000,
        }, {
+               .id             = "TL-WR740Nv1",
+               .hw_id          = HWID_TL_WR740N_V1,
+               .hw_rev         = 1,
+               .fw_max_len     = 0x3c0000,
+               .kernel_la      = 0x80060000,
+               .kernel_ep      = 0x80060000,
+               .rootfs_ofs     = 0x140000,
+       }, {
                .id             = "TL-WR841Nv1.5",
                .hw_id          = HWID_TL_WR841N_V1_5,
                .hw_rev         = 2,