[backfire] ar71xx: backport r23136 and r23138
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 18:11:54 +0000 (18:11 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 18:11:54 +0000 (18:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29031 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk

index 23747d5..070fe50 100755 (executable)
@@ -72,6 +72,9 @@ get_status_led() {
        tew-632brp)
                status_led="tew-632brp:green:status"
                ;;
+       tl-mr3420)
+               status_led="tl-mr3420:green:system"
+               ;;
        tl-wr1043nd)
                status_led="tl-wr1043nd:green:system"
                ;;
index 0ee701c..93d520a 100755 (executable)
@@ -82,6 +82,9 @@ ar71xx_board_name() {
        *TEW-632BRP)
                name="tew-632brp"
                ;;
+       *TL-MR3420)
+               name="tl-mr3420"
+               ;;
        *TL-WR1043ND)
                name="tl-wr1043nd"
                ;;
index 67f4048..8d21ba3 100755 (executable)
@@ -76,7 +76,7 @@ platform_check_image() {
                }
                return 0
                ;;
-       tl-wr741nd | tl-wr841n-v1 | tl-wr941nd | tl-wr1043nd)
+       tl-mr3420 | tl-wr741nd | tl-wr841n-v1 | tl-wr941nd | tl-wr1043nd)
                [ "$magic" != "0100" ] && {
                        echo "Invalid image type."
                        return 1
index ee04acb..5c7b321 100644 (file)
@@ -30,6 +30,7 @@ CONFIG_AR71XX_MACH_PB92=y
 CONFIG_AR71XX_MACH_RB4XX=y
 CONFIG_AR71XX_MACH_RB750=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_TL_MR3420=y
 CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR841N_V1=y
index 0b290f8..48fa294 100644 (file)
@@ -158,6 +158,15 @@ config AR71XX_MACH_MZK_W300NH
        select AR71XX_DEV_LEDS_GPIO
        default n
 
+config AR71XX_MACH_TL_MR3420
+       bool "TP-LINK TL-MR3420 support"
+       select AR71XX_DEV_M25P80
+       select AR71XX_DEV_AP91_PCI if PCI
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
+       default n
+
 config AR71XX_MACH_TL_WR741ND
        bool "TP-LINK TL-WR741ND support"
        select AR71XX_DEV_M25P80
index 690dd97..86f122c 100644 (file)
@@ -40,6 +40,7 @@ obj-$(CONFIG_AR71XX_MACH_PB92)                += mach-pb92.o
 obj-$(CONFIG_AR71XX_MACH_RB4XX)                += mach-rb4xx.o
 obj-$(CONFIG_AR71XX_MACH_RB750)                += mach-rb750.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
+obj-$(CONFIG_AR71XX_MACH_TL_MR3420)    += mach-tl-mr3420.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR841N_V1) += mach-tl-wr841n.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)   += mach-tl-wr941nd.o
index b6e68f8..e5419e2 100644 (file)
@@ -36,6 +36,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_MZK_W04NU,  /* Planex MZK-W04NU */
        AR71XX_MACH_MZK_W300NH, /* Planex MZK-W300NH */
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+       AR71XX_MACH_TL_MR3420,  /* TP-LINK TL-MR3420 */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
        AR71XX_MACH_TL_WR841N_V1, /* TP-LINK TL-WR841N v1 */
        AR71XX_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
index f39be3c..7033600 100644 (file)
@@ -493,6 +493,10 @@ define Image/Build/Profile/MZKW300NH
        $(call Image/Build/Template/$(fs_64k)/$(1),Planex,mzk-w300nh,board=MZK-W300NH)
 endef
 
+define Image/Build/Profile/TLMR3420V1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
+endef
+
 define Image/Build/Profile/TLWR741NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
@@ -566,6 +570,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/PB44,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLMR3420V1,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
index aab7fbc..493cf51 100644 (file)
@@ -5,6 +5,17 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3420V1
+       NAME:=TP-LINK TL-MR3420 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3420V1/Description
+       Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
        PACKAGES:=