refresh 2.6.30 patches
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 17:21:07 +0000 (17:21 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Nov 2011 17:21:07 +0000 (17:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29023 3c298f89-4303-0410-b956-a3cf2f4a3e73

22 files changed:
target/linux/generic-2.6/patches-2.6.30/014-cfi_fix_amd_extended_table_check.patch
target/linux/generic-2.6/patches-2.6.30/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.30/100-netfilter_layer7_2.21.patch
target/linux/generic-2.6/patches-2.6.30/110-netfilter_match_speedup.patch
target/linux/generic-2.6/patches-2.6.30/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.30/202-mips_mem_functions_performance.patch
target/linux/generic-2.6/patches-2.6.30/203-slab_maxsize.patch
target/linux/generic-2.6/patches-2.6.30/210-mini_fo_2.6.25_fixes.patch
target/linux/generic-2.6/patches-2.6.30/212-mini_fo_2.6.26_fixes.patch
target/linux/generic-2.6/patches-2.6.30/260-extend_pfifo_fast.patch
target/linux/generic-2.6/patches-2.6.30/400-ledtrig_morse.patch
target/linux/generic-2.6/patches-2.6.30/402-ledtrig_netdev.patch
target/linux/generic-2.6/patches-2.6.30/511-yaffs-cvs-2009-04-24.patch
target/linux/generic-2.6/patches-2.6.30/903-hostap_txpower.patch
target/linux/generic-2.6/patches-2.6.30/910-hostap_tx_queue_len_fix.patch
target/linux/generic-2.6/patches-2.6.30/924-cs5535_gpio.patch
target/linux/generic-2.6/patches-2.6.30/930-kmsg_dump_backport.patch
target/linux/generic-2.6/patches-2.6.30/941-ssb_update.patch
target/linux/generic-2.6/patches-2.6.30/943-ssb_commit_settings_export.patch
target/linux/generic-2.6/patches-2.6.30/965-arm_restore_sigmask_v2.patch
target/linux/generic-2.6/patches-2.6.30/971-ocf_20080917.patch
target/linux/generic-2.6/patches-2.6.30/990-fix_feroceon_vfp_handling.patch

index 3c7d303..1216a3b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -336,6 +336,8 @@ static struct cfi_fixup fixup_table[] = 
+@@ -336,6 +336,8 @@ static struct cfi_fixup fixup_table[] =
  static void cfi_fixup_major_minor(struct cfi_private *cfi,
                                  struct cfi_pri_amdstd *extp)
  {
@@ -9,7 +9,7 @@
        if (cfi->mfr == CFI_MFR_SAMSUNG && cfi->id == 0x257e &&
            extp->MajorVersion == '0')
                extp->MajorVersion = '1';
-@@ -366,6 +368,9 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -366,6 +368,9 @@ struct mtd_info *cfi_cmdset_0002(struct
        mtd->name    = map->name;
        mtd->writesize = 1;
  
@@ -19,7 +19,7 @@
        if (cfi->cfi_mode==CFI_MODE_CFI){
                unsigned char bootloc;
                /*
-@@ -384,16 +389,24 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -384,16 +389,24 @@ struct mtd_info *cfi_cmdset_0002(struct
  
                cfi_fixup_major_minor(cfi, extp);
  
index caabacc..6ff7504 100644 (file)
  
  unsigned int vced_count, vcei_count;
  
-@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file 
+@@ -33,8 +34,12 @@ static int show_cpuinfo(struct seq_file
        /*
         * For the first processor also print the system type
         */
index 8100b12..3791642 100644 (file)
@@ -71,7 +71,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -88,6 +88,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) 
+@@ -88,6 +88,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
index 926966c..e75d7aa 100644 (file)
  
                e = (struct ipt_entry *)(loc_cpu_entry + off);
                if (copy_to_user(userptr + off
-@@ -986,6 +1026,14 @@ copy_entries_to_user(unsigned int total_
+@@ -985,6 +1025,14 @@ copy_entries_to_user(unsigned int total_
+                       ret = -EFAULT;
                        goto free_counters;
                }
++
 +              flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
-+
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
-                    i += m->u.match_size) {
index 3bd7a8f..b4f2f4b 100644 (file)
  
  #ifdef CONFIG_NET_DMA
        dma_cookie_t            dma_cookie;
-@@ -423,6 +435,12 @@ extern void skb_dma_unmap(struct device 
+@@ -423,6 +435,12 @@ extern void skb_dma_unmap(struct device
                          enum dma_data_direction dir);
  #endif
  
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-@@ -1749,8 +1756,7 @@ u16 skb_tx_hash(const struct net_device 
+@@ -1749,8 +1756,7 @@ u16 skb_tx_hash(const struct net_device
  }
  EXPORT_SYMBOL(skb_tx_hash);
  
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const 
+@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
index 6ea9ba5..e432471 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/include/asm/string.h
 +++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__ 
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
  
  #define __HAVE_ARCH_MEMSET
  extern void *memset(void *__s, int __c, size_t __count);
index 25567f8..e3aa724 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/slab.h
 +++ b/include/linux/slab.h
-@@ -115,8 +115,8 @@ int kmem_ptr_validate(struct kmem_cache 
+@@ -115,8 +115,8 @@ int kmem_ptr_validate(struct kmem_cache
   * to do various tricks to work around compiler limitations in order to
   * ensure proper constant folding.
   */
index d71e3b6..b64630d 100644 (file)
@@ -61,7 +61,7 @@
  #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
  extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
  
-@@ -501,6 +505,29 @@ static inline void double_unlock(struct 
+@@ -501,6 +505,29 @@ static inline void double_unlock(struct
  #endif  /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
  #endif /* __KERNEL__ */
  
  #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
 --- a/fs/mini_fo/aux.c
 +++ b/fs/mini_fo/aux.c
-@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb, 
+@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
        err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
  
        /* validate */
index 8bd9ba3..b5fa64e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/mini_fo/super.c
 +++ b/fs/mini_fo/super.c
-@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int 
+@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
  #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
  
  
index ad9e9ba..2ad7adf 100644 (file)
@@ -85,7 +85,7 @@
  
        for (prio = 0; prio < PFIFO_FAST_BANDS; prio++)
                skb_queue_head_init(list + prio);
-@@ -453,9 +490,36 @@ static int pfifo_fast_init(struct Qdisc 
+@@ -453,9 +490,36 @@ static int pfifo_fast_init(struct Qdisc
        return 0;
  }
  
index 2754ed6..155144e 100644 (file)
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += 
+@@ -38,3 +38,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
  obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)  += ledtrig-backlight.o
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index c41fecf..8e2e5e8 100644 (file)
@@ -14,7 +14,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
+@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
index 5c70e79..c334b17 100644 (file)
                        dev->checkpointBlockList[i] = -1;
        }
  
-@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device 
+@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
  
  static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
  {
  {
        unsigned char cDelta;   /* column parity delta */
        unsigned lDelta;        /* line parity delta */
-@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
                return 0; /* no error */
  
        if (lDelta == ~lDeltaPrime &&
                /* Single bit (recoverable) error in data */
  
                bit = 0;
-@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
                if (cDelta & 0x02)
                        bit |= 0x01;
  
                        return -1;
  
                data[lDelta] ^= (1 << bit);
-@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
        }
  
        if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
                /* Reccoverable error in ecc */
  
                *read_ecc = *test_ecc;
-@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
        /* Unrecoverable error */
  
        return -1;
  {
        unsigned char *alias;
        int ret;
-@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry 
+@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
        return ret;
  }
  
  static int yaffs_file_flush(struct file *file, fl_owner_t id)
  #else
  static int yaffs_file_flush(struct file *file)
-@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file 
+@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
        yaffs_Device *dev = obj->myDev;
  
        T(YAFFS_TRACE_OS,
  
        yaffs_GrossLock(dev);
  
-@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct 
+@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
  
        yaffs_Device *dev;
  
        BUG_ON(!PageLocked(pg));
  #else
        if (!PageLocked(pg))
-@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct 
+@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
  
        yaffs_GrossLock(dev);
  
  
        yaffs_GrossUnlock(dev);
  
-@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct 
+@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
        flush_dcache_page(pg);
        kunmap(pg);
  
                if (n < step) {
                        n++;
                        continue;
-@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file 
+@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
        char *end;
        char *mask_name;
        const char *x;
        int i;
        int done = 0;
        int add, len = 0;
-@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file 
+@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
  
        while (!done && (pos < count)) {
                done = 1;
  
                switch (buf[pos]) {
                case '+':
-@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file 
+@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
                mask_name = NULL;
  
                mask_bitfield = simple_strtoul(buf + pos, &end, 0);
                                        mask_name = mask_flags[i].mask_name;
                                        mask_bitfield = mask_flags[i].mask_bitfield;
                                        done = 0;
-@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file 
+@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
  
                if (mask_name != NULL) {
                        done = 0;
                        case '-':
                                rg &= ~mask_bitfield;
                                break;
-@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file 
+@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
  
        yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
  
  {
        /* Get the real object in case we were fed a hard link as an equivalent object */
        equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
-@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object * 
+@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
  
  }
  
        int nToCopy;
        int n = nBytes;
        int nDone = 0;
-@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
        dev = in->myDev;
  
        while (n > 0) {
                        if (dev->nShortOpCaches > 0) {
  
                                /* If we can't find the data in the cache, then load it up. */
-@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
  
                                cache->locked = 1;
  
                                cache->locked = 0;
                        } else {
                                /* Read into the local buffer then copy..*/
-@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
                                    yaffs_GetTempBuffer(dev, __LINE__);
                                yaffs_ReadChunkDataFromObject(in, chunk,
                                                              localBuffer);
                }
  
                n -= nToCopy;
-@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
        return nDone;
  }
  
        int newFullChunks;
  
        yaffs_Device *dev = in->myDev;
-@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in, 
+@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
  
        yaffs_CheckGarbageCollection(dev);
  
  
        if (newSize < oldFileSize) {
  
-@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in, 
+@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
        }
  
  
  {
        obj = yaffs_GetEquivalentObject(obj);
  
-@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object * 
+@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
  
  
  
  {
        int init_failed = 0;
        unsigned x;
-@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
        dev->chunkOffset = 0;
        dev->nFreeChunks = 0;
  
        if (dev->startBlock == 0) {
                dev->internalStartBlock = dev->startBlock + 1;
                dev->internalEndBlock = dev->endBlock + 1;
-@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        /* Check geometry parameters. */
  
                return YAFFS_FAIL;
        }
  
-@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
                return YAFFS_FAIL;
        }
  
        /* Got the right mix of functions? */
        if (!yaffs_CheckDevFunctions(dev)) {
                /* Function missing */
-@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        dev->isMounted = 1;
  
  
        /*
         * Calculate chunkGroupBits.
-@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
        bits = ShiftsGE(x);
  
        /* Set up tnode width if wide tnodes are enabled. */
                dev->tnodeWidth = 16;
  
        dev->tnodeMask = (1<<dev->tnodeWidth)-1;
-@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
        dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
  
        /* Initialise temporary buffers and caches. */
                init_failed = 1;
  
        dev->srCache = NULL;
-@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
        if (!init_failed &&
            dev->nShortOpCaches > 0) {
                int i;
                        init_failed = 1;
  
                dev->srLastUse = 0;
-@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        dev->cacheHits = 0;
  
                                T(YAFFS_TRACE_ALWAYS,
                                  (TSTR("yaffs: restored from checkpoint" TENDSTR)));
                        } else {
-@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
                                dev->nBackgroundDeletions = 0;
                                dev->oldestDirtySequence = 0;
  
                /* Clean up the mess */
                T(YAFFS_TRACE_TRACING,
                  (TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
-@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
  
  }
  
  {
        if (etags) {
                memset(etags, 0, sizeof(*etags));
-@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags * 
+@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
   * Returns YAFFS_OK or YAFFS_FAIL.
   */
  int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
 +                      yaffs_UnpackTags2(tags, &pt);
 +              }
 +      }
--      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
--              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
 +      if (localData)
 +              yaffs_ReleaseTempBuffer(dev, data, __LINE__);
  
+-      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
 +      if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+               tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
        if (retval == 0)
                return YAFFS_OK;
        else
index 197d0a1..e220b0b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t 
+@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index b421662..cb7b040 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_main.c
 +++ b/drivers/net/wireless/hostap/hostap_main.c
-@@ -875,15 +875,16 @@ void hostap_setup_dev(struct net_device 
+@@ -875,15 +875,16 @@ void hostap_setup_dev(struct net_device
  
        switch(type) {
        case HOSTAP_INTERFACE_AP:
index 453affe..a36ea49 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/ioport.h>
  #include <linux/pci.h>
  #include <linux/smp_lock.h>
-@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[] 
+@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[]
  MODULE_DEVICE_TABLE(pci, divil_pci);
  
  static struct cdev cs5535_gpio_cdev;
index cdcf094..bcf3506 100644 (file)
@@ -55,7 +55,7 @@
  #include <linux/kallsyms.h>
  #include <linux/notifier.h>
  #include <linux/module.h>
-@@ -74,6 +75,7 @@ NORET_TYPE void panic(const char * fmt, 
+@@ -74,6 +75,7 @@ NORET_TYPE void panic(const char * fmt,
        dump_stack();
  #endif
  
index 391fbba..42ee93b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ssb/driver_chipcommon_pmu.c
 +++ b/drivers/ssb/driver_chipcommon_pmu.c
-@@ -28,6 +28,21 @@ static void ssb_chipco_pll_write(struct 
+@@ -28,6 +28,21 @@ static void ssb_chipco_pll_write(struct
        chipco_write32(cc, SSB_CHIPCO_PLLCTL_DATA, value);
  }
  
@@ -43,7 +43,7 @@
                /* We keep the default settings:
                 * min_msk = 0xCBB
                 * max_msk = 0x7FFFF
-@@ -506,3 +528,82 @@ void ssb_pmu_init(struct ssb_chipcommon 
+@@ -506,3 +528,82 @@ void ssb_pmu_init(struct ssb_chipcommon
        ssb_pmu_pll_init(cc);
        ssb_pmu_resources_init(cc);
  }
  
  static inline u8 ssb_crc8(u8 crc, u8 data)
  {
-@@ -247,7 +253,7 @@ static int sprom_do_read(struct ssb_bus 
+@@ -247,7 +253,7 @@ static int sprom_do_read(struct ssb_bus
        int i;
  
        for (i = 0; i < bus->sprom_size; i++)
  
        /* Extract the antenna gain values. */
        SPEX(antenna_gain.ghz24.a0, SSB_SPROM8_AGAIN01,
-@@ -549,6 +600,7 @@ static int sprom_extract(struct ssb_bus 
+@@ -549,6 +600,7 @@ static int sprom_extract(struct ssb_bus
                        ssb_printk(KERN_WARNING PFX "Unsupported SPROM"
                                   "  revision %d detected. Will extract"
                                   " v1\n", out->revision);
        }
        bus->mmio = NULL;
        bus->mapped_device = NULL;
-@@ -230,6 +240,8 @@ static void __iomem *ssb_ioremap(struct 
+@@ -230,6 +240,8 @@ static void __iomem *ssb_ioremap(struct
                SSB_BUG_ON(1); /* Can't reach this code. */
  #endif
                break;
index 2bd5512..7726809 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ssb/driver_pcicore.c
 +++ b/drivers/ssb/driver_pcicore.c
-@@ -476,30 +476,6 @@ static void ssb_pcie_mdio_write(struct s
+@@ -505,30 +505,6 @@ static void ssb_pcie_mdio_write(struct s
        pcicore_write32(pc, mdio_control, 0);
  }
  
@@ -33,7 +33,7 @@
  {
 --- a/drivers/ssb/main.c
 +++ b/drivers/ssb/main.c
-@@ -1406,6 +1406,31 @@ error:
+@@ -1301,6 +1301,31 @@ error:
  }
  EXPORT_SYMBOL(ssb_bus_powerup);
  
@@ -67,7 +67,7 @@
        u32 base = 0;
 --- a/include/linux/ssb/ssb.h
 +++ b/include/linux/ssb/ssb.h
-@@ -675,6 +675,7 @@ extern int ssb_bus_may_powerdown(struct 
+@@ -671,6 +671,7 @@ extern int ssb_bus_may_powerdown(struct
   * Otherwise static always-on powercontrol will be used. */
  extern int ssb_bus_powerup(struct ssb_bus *bus, bool dynamic_pctl);
  
index 30acd03..c8f0bf5 100644 (file)
@@ -261,7 +261,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  handle_signal(unsigned long sig, struct k_sigaction *ka,
              siginfo_t *info, sigset_t *oldset,
              struct pt_regs * regs, int syscall)
-@@ -592,7 +557,7 @@ handle_signal(unsigned long sig, struct 
+@@ -592,7 +557,7 @@ handle_signal(unsigned long sig, struct
  
        if (ret != 0) {
                force_sigsegv(sig, tsk);
@@ -270,7 +270,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
        }
  
        /*
-@@ -606,6 +571,7 @@ handle_signal(unsigned long sig, struct 
+@@ -606,6 +571,7 @@ handle_signal(unsigned long sig, struct
        recalc_sigpending();
        spin_unlock_irq(&tsk->sighand->siglock);
  
@@ -278,7 +278,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
  }
  
  /*
-@@ -617,11 +583,12 @@ handle_signal(unsigned long sig, struct 
+@@ -617,11 +583,12 @@ handle_signal(unsigned long sig, struct
   * the kernel can handle, and then we build all the user-level signal handling
   * stack-frames in one go after that.
   */
index 869323f..1d3f685 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -712,6 +722,61 @@ void add_disk_randomness(struct gendisk 
+@@ -712,6 +722,61 @@ void add_disk_randomness(struct gendisk
  }
  #endif
  
index 0ee18f0..8d986d4 100644 (file)
@@ -53,7 +53,7 @@ Cc: Nicolas Pitre <nico@cam.org>
  check_for_exception:
 --- a/arch/arm/vfp/vfpmodule.c
 +++ b/arch/arm/vfp/vfpmodule.c
-@@ -253,12 +253,14 @@ void VFP_bounce(u32 trigger, u32 fpexc, 
+@@ -253,12 +253,14 @@ void VFP_bounce(u32 trigger, u32 fpexc,
        }
  
        if (fpexc & FPEXC_EX) {