[package] mjpg-streamer: install web pages (#6499)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Aug 2012 15:38:41 +0000 (15:38 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Aug 2012 15:38:41 +0000 (15:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33059 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/mjpg-streamer/Makefile
multimedia/mjpg-streamer/files/mjpg-streamer.config
multimedia/mjpg-streamer/files/mjpg-streamer.init

index 9593f98..9f178a3 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mjpg-streamer
 PKG_REV:=148
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://mjpg-streamer.svn.sourceforge.net/svnroot/mjpg-streamer/mjpg-streamer/
@@ -46,6 +46,8 @@ define Package/mjpg-streamer/install
        $(CP) $(foreach output_plugin,http file,$(PKG_BUILD_DIR)/output_$(output_plugin).so) $(1)/usr/lib
        $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
        $(INSTALL_DATA) ./files/mjpg-streamer.hotplug $(1)/etc/hotplug.d/usb/20-mjpg-streamer
+       $(INSTALL_DIR) $(1)/www/webcam
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/www/* $(1)/www/webcam
 endef
 
 define Package/mjpg-streamer/conffiles
index 5691c3a..5be37ea 100644 (file)
@@ -3,4 +3,5 @@ config mjpg-streamer core
        option device           "/dev/video0"
        option resolution       "640x480"
        option fps              "5"
+       option www              "/www/webcam"
        option port             "8080"
index 5a45968..b0a2043 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 
 START=50
 
@@ -25,6 +25,7 @@ start_instance() {
        config_get device "$s" 'device'
        config_get resolution "$s" 'resolution'
        config_get fps "$s" 'fps'
+       config_get www "$s" 'www'
        config_get port "$s" 'port'
 
        [ -c "$device" ] || {
@@ -34,7 +35,7 @@ start_instance() {
 
        service_start /usr/bin/mjpg_streamer --input "input_uvc.so \
                --device $device --fps $fps --resolution $resolution" \
-               --output "output_http.so --port $port"
+               --output "output_http.so --www $www --port $port"
 }
 
 stop_instance() {