[package] xmail: cope with empty flags options (#9452)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Aug 2012 15:38:40 +0000 (15:38 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Aug 2012 15:38:40 +0000 (15:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33058 3c298f89-4303-0410-b956-a3cf2f4a3e73

mail/xmail/Makefile
mail/xmail/files/xmail.init

index 7ff16fb..e756c05 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xmail
 PKG_VERSION:=1.26
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xmailserver.org/
index 2f5abd5..2b4990b 100644 (file)
@@ -13,7 +13,7 @@ append_bool() {
        local option="$2"
        local value="$3"
        local _loctmp
-       config_get_bool _loctmp "$section" "$option"
+       config_get_bool _loctmp "$section" "$option" 0
        [ "$_loctmp" -le 0 ] && return 0
        append args "$value"
 }