pciutils: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 08:57:44 +0000 (08:57 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jun 2014 08:57:44 +0000 (08:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41110 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/pciutils/Makefile [deleted file]
utils/pciutils/patches/100-remove-no-timestamping.patch [deleted file]
utils/pciutils/patches/101-no-strip.patch [deleted file]
utils/pciutils/patches/102-compressed-ids.patch [deleted file]
utils/pciutils/patches/103-relative-path-ids.patch [deleted file]
utils/pciutils/patches/104-resolv.patch [deleted file]

diff --git a/utils/pciutils/Makefile b/utils/pciutils/Makefile
deleted file mode 100644 (file)
index 93f35e0..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pciutils
-PKG_VERSION:=3.2.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
-PKG_MD5SUM:=d73a1b35e5d5efa70e8476d5917de11f
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/pciutils
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Linux PCI Utilities
-  URL:=http://mj.ucw.cz/pciutils.shtml
-  DEPENDS:=+zlib
-endef
-
-define Package/pciutils/description
- contains collection of programs for inspecting and manipulating configuration
- of PCI devices
-endef
-
-define Package/pciutils/postinst
-#!/bin/sh
-[ -z "$${IPKG_INSTROOT}" ] || \
-(cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids; rm pci.ids.gz.old)
-exit 0
-endef
-
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       PREFIX="/usr" \
-       HOST="$(GNU_TARGET_NAME)" \
-       ZLIB="yes" \
-
-ifneq ($(CONFIG_USE_EGLIBC),)
-TARGET_LDFLAGS += -lresolv
-endif
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib
-       $(INSTALL_DIR) $(1)/usr/include/pci
-       $(CP) $(foreach i,pci.h config.h header.h types.h, \
-               $(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci
-endef
-
-define Package/pciutils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/share
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids.gz $(1)/usr/share/
-endef
-
-$(eval $(call BuildPackage,pciutils))
diff --git a/utils/pciutils/patches/100-remove-no-timestamping.patch b/utils/pciutils/patches/100-remove-no-timestamping.patch
deleted file mode 100644 (file)
index 93bc85f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/update-pciids.sh
-+++ b/update-pciids.sh
-@@ -33,7 +33,7 @@ if which curl >/dev/null 2>&1 ; then
-       DL="curl -o $DEST.new $SRC"
-     ${quiet} && DL="$DL -s -S"
- elif which wget >/dev/null 2>&1 ; then
--      DL="wget --no-timestamping -O $DEST.new $SRC"
-+      DL="wget -O $DEST.new $SRC"
-       ${quiet} && DL="$DL -q"
- elif which lynx >/dev/null 2>&1 ; then
-       DL="eval lynx -source $SRC >$DEST.new"
diff --git a/utils/pciutils/patches/101-no-strip.patch b/utils/pciutils/patches/101-no-strip.patch
deleted file mode 100644 (file)
index 583eb9a..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -108,7 +108,7 @@ distclean: clean
- install: all
- # -c is ignored on Linux, but required on FreeBSD
-       $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7
--      $(INSTALL) -c -m 755 $(STRIP) lspci setpci $(DESTDIR)$(SBINDIR)
-+      $(INSTALL) -c -m 755 lspci setpci $(DESTDIR)$(SBINDIR)
-       $(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
-       $(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(IDSDIR)
-       $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
diff --git a/utils/pciutils/patches/102-compressed-ids.patch b/utils/pciutils/patches/102-compressed-ids.patch
deleted file mode 100644 (file)
index 9b31938..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/update-pciids.sh
-+++ b/update-pciids.sh
-@@ -6,9 +6,8 @@ set -e
- SRC="http://pci-ids.ucw.cz/v2.2/pci.ids"
- DEST=pci.ids
- PCI_COMPRESSED_IDS=
--GREP=grep
--# if pci.ids is read-only (because the filesystem is read-only),
-+# if pci.ids.gz is read-only (because the filesystem is read-only),
- # then just skip this whole process.
- if ! touch ${DEST} >/dev/null 2>&1 ; then
-       ${quiet} || echo "${DEST} is read-only, exiting." 1>&2
-@@ -18,7 +17,7 @@ fi
- if [ "$PCI_COMPRESSED_IDS" = 1 ] ; then
-       DECOMP="cat"
-       SRC="$SRC.gz"
--      GREP=zgrep
-+      DEST="$DEST.gz"
- elif which bzip2 >/dev/null 2>&1 ; then
-       DECOMP="bzip2 -d"
-       SRC="$SRC.bz2"
-@@ -53,7 +52,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
-       exit 1
- fi
--if ! $GREP >/dev/null "^C " $DEST.neww ; then
-+if ! zcat $DEST.neww | grep >/dev/null "^C " ; then
-       echo >&2 "update-pciids: missing class info, probably truncated file"
-       exit 1
- fi
diff --git a/utils/pciutils/patches/103-relative-path-ids.patch b/utils/pciutils/patches/103-relative-path-ids.patch
deleted file mode 100644 (file)
index 9c1a067..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -85,7 +85,7 @@ lspci: LDLIBS+=$(LIBKMOD_LIBS)
- ls-kernel.o: CFLAGS+=$(LIBKMOD_CFLAGS)
- update-pciids: update-pciids.sh
--      sed <$< >$@ "s@^DEST=.*@DEST=$(IDSDIR)/$(PCI_IDS)@;s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
-+      sed <$< >$@ "s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
-       chmod +x $@
- # The example of use of libpci
diff --git a/utils/pciutils/patches/104-resolv.patch b/utils/pciutils/patches/104-resolv.patch
deleted file mode 100644 (file)
index dbd46aa..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/configure
-+++ b/lib/configure
-@@ -57,7 +57,7 @@ echo >>$c "#define PCI_OS_`echo $sys | t
- echo >$m 'WITH_LIBS='
- echo_n "Looking for access methods..."
--LIBRESOLV=-lresolv
-+LIBRESOLV=
- case $sys in
-       linux*)