flashrom: moved to github
[packages.git] / utils / setserial / Makefile
index ceca835..b097c54 100644 (file)
@@ -1,23 +1,20 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=setserial
 PKG_VERSION:=2.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/setserial
 PKG_MD5SUM:=c4867d72c41564318e0107745eb7a0f2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/setserial
@@ -25,14 +22,14 @@ define Package/setserial
   CATEGORY:=Utilities
   TITLE:=Serial port configuration utility
   URL:=http://setserial.sourceforge.net/
-  SUBMENU:=terminal
+  SUBMENU:=Terminal
 endef
 
 define Package/setserial/description
-       setserial is a program designed to set and/or report the 
-       configuration information associated with a serial port. This 
-       information includes what I/O port and IRQ a particular 
-       serial port is using, and whether or not the break key should 
+       setserial is a program designed to set and/or report the
+       configuration information associated with a serial port. This
+       information includes what I/O port and IRQ a particular
+       serial port is using, and whether or not the break key should
        be interpreted as the Secure Attention Key, and so on.
 endef
 
@@ -40,14 +37,20 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               all
+               setserial
 endef
 
 define Package/setserial/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/setserial $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/setserial.config $(1)/etc/config/setserial
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/serial.init $(1)/etc/init.d/setserial
+       $(INSTALL_BIN) ./files/setserial.init $(1)/etc/init.d/setserial
+endef
+
+define Package/setserial/conffiles
+/etc/config/setserial
 endef
 
 $(eval $(call BuildPackage,setserial))