dansguardian: moved to github
[packages.git] / net / raddump / Makefile
index 2a9973f..ad7c367 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,10 +14,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/raddump
 PKG_MD5SUM:=f8c29c67141ea78bb6ae8b97d5149480
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,25 +24,21 @@ define Package/raddump
   CATEGORY:=Network
   DEPENDS:=+libpcap +libopenssl
   TITLE:=raddump interprets captured RADIUS packets.
-  DESCRIPTION:=\
-       raddump interprets captured RADIUS packets to print a \\\
-       timestamp, packet length, RADIUS packet type, source and \\\
-       destination hosts and ports, and included attribute names and \\\
-       values for each packet.
   URL:=http://sourceforge.net/projects/raddump
 endef
 
-# uses GNU configure
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Package/raddump/description
+       raddump interprets captured RADIUS packets to print a
+       timestamp, packet length, RADIUS packet type, source and
+       destination hosts and ports, and included attribute names and
+       values for each packet.
 endef
 
-define Package/raddump/install 
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/raddump $(1)/usr/bin/
+# uses GNU configure
+
+define Package/raddump/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/raddump $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,raddump))