dansguardian: moved to github
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 28 Jan 2015 01:04:58 +0000 (01:04 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 28 Jan 2015 01:04:58 +0000 (01:04 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@44159 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/dansguardian/Makefile [deleted file]
net/dansguardian/patches/001-include_dir.patch [deleted file]

diff --git a/net/dansguardian/Makefile b/net/dansguardian/Makefile
deleted file mode 100644 (file)
index bba2d8b..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (C) 2008-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dansguardian
-PKG_VERSION:=2.10.1.1
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Stable
-PKG_MD5SUM:=0987a1c9bfbdf398118386f10279611a
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/uclibc++.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/dansguardian
-  SECTION:=net
-  DEPENDS:=+libpthread $(CXX_DEPENDS) +zlib
-  CATEGORY:=Network
-  SUBMENU:=Web Servers/Proxies
-  TITLE:=DansGuardian
-  URL:=http://dansguardian.org
-endef
-
-define Package/dansguardian/conffiles
-/etc/dansguardian/dansguardian.conf
-endef
-
-CONFIGURE_VARS += \
-       INCLUDES="" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti"  \
-       LIBS="-lpthread" \
-
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --disable-clamav \
-               --with-sysconfsubdir=dansguardian \
-               --with-proxyuser=root \
-               --with-proxygroup=root \
-               --disable-pcre \
-       )
-endef
-
-define Package/dansguardian/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dansguardian $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc
-       $(CP) $(PKG_INSTALL_DIR)/etc/dansguardian $(1)/etc/
-       $(INSTALL_DIR) $(1)/usr/share/dansguardian
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/dansguardian/transparent1x1.gif $(1)/usr/share/dansguardian/
-       $(INSTALL_DIR) $(1)/usr/share/dansguardian/languages/ukenglish
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/dansguardian/languages/ukenglish/* $(1)/usr/share/dansguardian/languages/ukenglish/
-endef
-
-$(eval $(call BuildPackage,dansguardian))
diff --git a/net/dansguardian/patches/001-include_dir.patch b/net/dansguardian/patches/001-include_dir.patch
deleted file mode 100644 (file)
index 8a619f0..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -861,7 +861,7 @@ sysconfdir='${prefix}/etc'
- sharedstatedir='${prefix}/com'
- localstatedir='${prefix}/var'
- includedir='${prefix}/include'
--oldincludedir='/usr/include'
-+oldincludedir='${prefix}/usr/include'
- docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
- infodir='${datarootdir}/info'
- htmldir='${docdir}'
-@@ -6317,7 +6317,7 @@ $as_echo_n "checking for zlib... " >&6; 
- # Check whether --with-zlib was given.
- if test "${with_zlib+set}" = set; then
-   withval=$with_zlib;  # check for header & func (in library) in given prefix
--      CPPFLAGS="${CPPFLAGS} -I${withval}/include"
-+      CPPFLAGS="${CPPFLAGS}"
-       if test "x$staticzlib" = "xtrue"; then
-               LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
-       else
-@@ -10042,7 +10042,7 @@ _ACEOF
- if test "${with_libiconv+set}" = set; then
-   withval=$with_libiconv;  # check for header & func (in library) in given prefix
-                       if test "x$withval" != "x"; then
--                              CPPFLAGS="${CPPFLAGS} -I${withval}/include"
-+                              CPPFLAGS="${CPPFLAGS}"
-                               LIBS="-L${withval}/lib -liconv ${LIBS}"
-                       else
-                               LIBS="-liconv ${LIBS}"