libosip2: moved to telephony feed
[packages.git] / libs / nmeap / Makefile
index d0629e1..66589da 100644 (file)
@@ -1,10 +1,9 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -22,23 +21,21 @@ define Package/libnmeap
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=extensible NMEA-0183 parser written in standard C
-  DESCRIPTION:=The NMEAP parser is intended for use in applications that need to input NMEA-0183 \\\
-       data from a GPS (typically over a serial port). NMEAP is a linkable library written in portable \\\
-       standard C and is suitable for both desktop and embedded applications. \\\
-       It is licensed under the BSD open source license.
   URL:=http://www.dmh2000.com/nmea/nmeap.shtml
 endef
 
-define Build/InstallDev
-       $(INSTALL_DIR) $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/inc/nmeap{,_def}.h $(STAGING_DIR)/usr/include/
-       $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/lib/libnmeap.a $(STAGING_DIR)/usr/lib/
+define Package/libnmeap/description
+The NMEAP parser is intended for use in applications that need to input NMEA-0183
+       data from a GPS (typically over a serial port). NMEAP is a linkable library written in portable
+       standard C and is suitable for both desktop and embedded applications.
+       It is licensed under the BSD open source license.
 endef
 
-define Build/UninstallDev
-       rm -f $(STAGING_DIR)/usr/include/nmeap{,_def}.h \
-               $(STAGING_DIR)/usr/lib/libnmeap.a
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/inc/nmeap{,_def}.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnmeap.a $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libnmeap))