libosip2: moved to telephony feed
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Jul 2014 10:17:54 +0000 (10:17 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Jul 2014 10:17:54 +0000 (10:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41739 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libosip2/Makefile [deleted file]
libs/libosip2/patches/001-automake-compat.patch [deleted file]

diff --git a/libs/libosip2/Makefile b/libs/libosip2/Makefile
deleted file mode 100644 (file)
index 19d61f7..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-#
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libosip2
-PKG_VERSION:=3.5.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/osip
-PKG_MD5SUM:=7691546f6b3349d10007fc1aaff0f4e0
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libosip2
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=GNU oSIP library
-  URL:=http://www.gnu.org/software/osip/
-  DEPENDS:=+libpthread
-endef
-
-define Package/libosip2description
- GNU oSIP library, a Session Initiation Protocol (SIP) implementation.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-debug \
-               --disable-trace \
-               --enable-pthread \
-               --enable-semaphore \
-       )
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/osip{,parser}2 $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.{a,so*} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libosip2.pc $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/libosip2/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.so $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libosip2))
diff --git a/libs/libosip2/patches/001-automake-compat.patch b/libs/libosip2/patches/001-automake-compat.patch
deleted file mode 100644 (file)
index 9c0bc11..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,3 +1,5 @@
-+ACLOCAL_AMFLAGS = -I scripts
-+
- EXTRA_DIST = README BUGS FEATURES HISTORY autogen.sh libosip2.pc.in
- SUBDIRS = include src scripts help platform