libdbi: moved to github
[packages.git] / libs / libshout / Makefile
index a3ac2ff..af12afa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libshout
-PKG_VERSION:=2.2.2
+PKG_VERSION:=2.3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/libshout/
-PKG_MD5SUM:=4f75fc9901c724b712c371c9a1e782d3
+PKG_MD5SUM:=11765b2592e7ea623ccd93d3f8df172c
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
 define Package/libshout
   SECTION:=libs
-  DEPENDS:=+libvorbisidec
+  DEPENDS:= +libspeex +libtheora +libvorbis +libvorbisidec +libpthread
   CATEGORY:=Libraries
   TITLE:=Library which can be used to write a source client like ices
   URL:=http://www.icecast.org/download.php
@@ -37,21 +40,13 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
-               VORBIS_LIBS="$(TARGET_LDFLAGS)" \
+               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
+               VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
                --enable-shared \
                --enable-static \
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/shout
        $(CP) $(PKG_INSTALL_DIR)/usr/include/shout/shout.h $(1)/usr/include/shout