libdbi: moved to github
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Aug 2014 09:29:31 +0000 (09:29 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Aug 2014 09:29:31 +0000 (09:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42267 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libdbi/Makefile [deleted file]

diff --git a/libs/libdbi/Makefile b/libs/libdbi/Makefile
deleted file mode 100644 (file)
index e27b09a..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2009-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libdbi
-PKG_VERSION:=0.9.0
-PKG_RELEASE:=4
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/libdbi
-PKG_MD5SUM:=05e2ceeac4bc85fbe40de8b4b22d9ab3
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libdbi
-  NAME:=libdbi
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE+= (library)
-  URL:=http://libdbi.sourceforge.net/
-endef
-
-define Package/libdbi/description
-       libdbi implements a database-independent abstraction layer in C.
-endef
-
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --disable-docs
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/dbi $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbi.{a,so*} $(1)/usr/lib/
-endef
-
-define Package/libdbi/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbi.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libdbi))