Rework LuCI build system
[project/luci.git] / modules / luci-mod-admin-full / src / Makefile
diff --git a/modules/luci-mod-admin-full/src/Makefile b/modules/luci-mod-admin-full/src/Makefile
new file mode 100644 (file)
index 0000000..47045fc
--- /dev/null
@@ -0,0 +1,14 @@
+%.o: %.c
+       $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -c -o $@ $<
+
+clean:
+       rm -f luci-bwc *.o
+
+luci-bwc: luci-bwc.o
+       $(CC) $(LDFLAGS) -shared -o $@ $^
+
+compile: luci-bwc
+
+install: compile
+       mkdir -p $(DESTDIR)/usr/bin
+       cp luci-bwc $(DESTDIR)/usr/bin/luci-bwc