Rework LuCI build system
[project/luci.git] / modules / luci-base / src / Makefile
diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile
new file mode 100644 (file)
index 0000000..7bb7f2e
--- /dev/null
@@ -0,0 +1,21 @@
+%.o: %.c
+       $(CC) $(CPPFLAGS) $(CFLAGS) $(FPIC) -c -o $@ $<
+
+clean:
+       rm -f po2lmo parser.so version.lua *.o
+
+po2lmo: po2lmo.o template_lmo.o
+       $(CC) $(LDFLAGS) -o $@ $^
+
+parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o
+       $(CC) $(LDFLAGS) -shared -o $@ $^
+
+version.lua:
+       ./mkversion.sh $@ $(LUCI_VERSION)
+
+compile: parser.so version.lua
+
+install: compile
+       mkdir -p $(DESTDIR)/usr/lib/lua/luci/template
+       cp parser.so $(DESTDIR)/usr/lib/lua/luci/template/parser.so
+       cp version.lua $(DESTDIR)/usr/lib/lua/luci/version.lua