libs/nixio: link with libcrypto when using OpenSSL as digest backend
[project/luci.git] / libs / nixio / Makefile
index 42d3666..fd2e06a 100644 (file)
@@ -32,7 +32,7 @@ ifeq ($(NIXIO_TLS),axtls)
 endif
 
 ifeq ($(NIXIO_TLS),openssl)
-       NIXIO_LDFLAGS += -lssl
+       NIXIO_LDFLAGS += -lssl -lcrypto
 endif
 
 ifeq ($(NIXIO_TLS),cyassl)