* Added preliminary HTTPD construct
[project/luci.git] / libs / httpd / Makefile
diff --git a/libs/httpd/Makefile b/libs/httpd/Makefile
new file mode 100644 (file)
index 0000000..ee1a40e
--- /dev/null
@@ -0,0 +1,13 @@
+include ../../build/module.mk
+include ../../build/config.mk
+include ../../build/gccconfig.mk
+
+%.o: %.c
+       $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $< 
+
+compile: src/fastindex.o
+       mkdir -p dist$(LUCI_LIBRARYDIR)
+       $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_LIBRARYDIR)/fastindex.so src/fastindex.o $(LUA_SHLIBS)
+
+clean:
+       rm -f src/*.o