Integrate core C implementation
[project/luci.git] / libs / core / Makefile
index f7fac77..7c9b3d7 100644 (file)
@@ -1,2 +1,12 @@
 include ../../build/config.mk
 include ../../build/module.mk
+
+%.o: %.c
+       $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: src/luci_cutil.o
+       mkdir -p dist$(LUCI_LIBRARYDIR)
+       $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_LIBRARYDIR)/cutil.so src/luci_cutil.o
+
+clean: luaclean
+       rm src/*.o
\ No newline at end of file