Renamed reworked UCI API to uci2 to allow a peaceful coexistence with the old one
[project/luci.git] / contrib / uci / Makefile
index bce79eb..1363b78 100644 (file)
@@ -53,7 +53,7 @@ compile: $(UCI_DIR)/.patched
        $(MAKE) -C $(UCI_DIR) install DESTDIR=../dist prefix=/usr
        $(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
        $(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
-
+       mv dist$(LUA_LIBRARYDIR)/uci.so dist$(LUA_LIBRARYDIR)/uci2.so
 
 compile-all: compile