More stuff enabled in config, fix squashfs image, thanks sn9
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index df920dd..d6f4982 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=squashfs
+FEATURES:=squashfs jffs2
 
 define Target/Description
         Build firmware images for RDC3211 based routers
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/kernel-build.mk
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     define Kernel/SetInitramfs
        rm -f $(BUILD_DIR)/root/sbin/init
-       $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/sbin/
+       ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
        $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
     endef
 endif